Find the answer to your Linux question:
Results 1 to 2 of 2
Ok so I installed Arch linux on Oracle VM virtual box in lubuntu. I am trying to setup my wifi, but can't even find my wifi card in arch. When ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    10

    Arch Virtual Box wifi setup


    Ok so I installed Arch linux on Oracle VM virtual box in lubuntu. I am trying to setup my wifi, but can't even find my wifi card in arch. When try to find my card my card in lubuntu I get this
    lspci | grep -i net
    02:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
    09:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    When I run the same commandin Arch linux in the Virtual Box I get
    00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit ethernet Controller (rev 02)
    Based on what I got in lubuntu I tried running modprobe ath5k since according to lubuntu I have an AR242x / AR542x Wireless Network Adapter. I then ran ip link and it came up with 1. lo: <LOOPBACK,UP,LOWER,UP> and then a line or two of other things written after that. And 2. eth0 <BROADCAST,MULTITASK> and then another line or two of code. I'm new to linux and wanted mess a little around with Arch so if you can give me an answer please describe step fro step. Thank you.

  2. #2
    Just Joined! charleseddy's Avatar
    Join Date
    Mar 2012
    Location
    France
    Posts
    27
    This is a very simple problem.

    Virtualbox doesn't use the wifi hardware that you have. It creates a virtual ethernet card (generally one that is very well supported across all OSs, such as the Intel you selected in your network settings for the Arch virtual machine used), and passes the internet connection from your host machine along to the VM.

    Can you not connect to the Internet on your Arch VM? If so, it's almost certainly a configuration error in the network settings for your virtual machine and not in linux: double check the settings (and use the VirtualBox online manual to get more information about how it works, it's there for a reason!!!!!).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •