Find the answer to your Linux question:
Results 1 to 2 of 2
My hardware: PIII 1GHz, 1GB DDR, 60GB IDE HD, Intel Graphic and Pluscom Realtek (rtl8188cus) wireless usb dongle. Newest Arch edition (August 2012) My wireless works during the live cd ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    2

    Trouble with RTL8188cus wireless chipset. Authentication Failed.


    My hardware:

    PIII 1GHz, 1GB DDR, 60GB IDE HD, Intel Graphic and Pluscom Realtek (rtl8188cus) wireless usb dongle.

    Newest Arch edition (August 2012)

    My wireless works during the live cd and through the main installation.

    How come wireless device stops working AFTER completed the installation? I have heard that a lot.

    I did exactly the same commands before and AFTER the main installation:

    wpa_passphrase candyland "0123456789" > /etc/wpa_supplicant.conf
    ip link set wlan0 up
    wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf
    dhcpcd wlan0

    It just timed out after the dhcpcd wlan0 part.

    The device is there by usig iwconfig and I noticed the Access Point shows Not-Associated.

    Surely, if it worked before the installation it should work AFTER the post-installation as well? Am I missing something?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Ah yes. The good old linux "It works with the Live CD/DVD drive, but not after I install it!" problem. This is usually due to the fact that the Live versions include a lot of proprietary wireless drivers that are needed to run the WiFi chip sets installed in your system (laptops usually); however, many distributions do NOT install the proprietary drivers by default so they can claim to be fully FOSS (Free and Open Source) compliant. IE, you will have to install the required drivers manually. A good site to determine what drivers are best for your distribution and hardware is Welcome - Linux Wireless. Some distributions, such as Debian and Ubuntu, also have a package set of proprietary (non-open source) drivers and such that you can enable, and then install the drivers your system needs. This is a major (in my opinion) PITA. Example: before Ubuntun 9.10 (9.04 and earlier), these drivers were installed as needed on installation of the OS. I could use ANY WiFi or USB broadband modem card/dongle/whatever without installing drivers or configuring - they just worked "out-of-the-box". With Ubuntu 9.10 and later, this is no longer the case, even using the exact same hardware! Now, it usually takes me a day or so to get wireless working when I install a new distribution on a system, and I have done this many times on many different systems. This is the crux of my biggest gripe about Linux. I just wish people would get over their aversion of using proprietary hardware drivers and firmware blobs. It just keeps us from moving forward!
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •