Find the answer to your Linux question:
Results 1 to 6 of 6
https [colon] //wiki [dot] archlinux [dot] org/index [dot] php/Beginners%27_Guide#Extra (replace the [dot]'s with .'s, same with colons) On the Arch Wiki page using my "live" CD, I have followed all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4

    Trouble following Beginner's Installation Instructions on Arch Wiki


    https [colon] //wiki [dot] archlinux [dot] org/index [dot] php/Beginners%27_Guide#Extra

    (replace the [dot]'s with .'s, same with colons)

    On the Arch Wiki page using my "live" CD, I have followed all the directions until the 'Extra' subsection. I rebooted as directed in the instructions and got stuck in Grub2. The instructions say that I should be able to login now, but I don't see any way of doing this.

    I've re-read the instructions and don't seem to understand what went wrong. Keep in mind I haven't done any of the things listed on the 'Extra' subsection yet, so I have not loaded X, Alsa, or other things. I don't even have a normal terminal prompt, its the Grub2 prompt.

    Is this problem with the partitions? problem with the Arch install? problem with my "live" CD?

    If you need any information to help me solve this problem let me know, but I'm on a windows machine right now so I can't copy and paste any direct code.

  2. #2
    Just Joined!
    Join Date
    Jan 2013
    Location
    Russia, Nizhny Archyz
    Posts
    14
    Can you tell in detail what's happend after you boot grub2?
    Does it have boot menu? Did you see boot messages?
    Maybe you forgot to install grub properly? Have you any error messages?

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4
    I'm pretty sure I didn't do something right, because after I boot the computer the messages read:

    Booting...
    GRUB loading.
    Welcome to GRUB!

    error: file '/grub/i386-pc/normal.mod' not found.
    Entering rescue mode...
    grub rescue> _

    (that last underline is where the cursor is)

    I'll try to reload the live cd, and do the installation procedures again and report back here (although when I tried previously I wasn't able to get arch-chroot working--something about sys being mounted already??)

    What do you think of this?

  4. #4
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4
    As I expected I got stuck in arch-chroot part of the installation again. Why is this happening? More specifically:

    # arch-chroot /mnt
    mount: sys is already mounted or /mnt/sys busy
    sys is already mounted on /sys
    sys is already mounted on /mnt/sys
    ==> ERROR: failed to setup API filesystems in chroot /mnt

    But, I don't understand why I'm getting this error, since I never mounted sys to anything--I don't even know what sys is supposed to be?
    The first time I went through the installation instructions the arch-chroot command worked fine, now why is it giving me problems. Did sys get mounted the first time and now stayed mounted, even though I rebooted a number of times afterward? Was it wrong for me to believe that everything is automatically unmounted after reboot?

    If anyone knows the answer please let me know.

  5. #5
    Just Joined!
    Join Date
    Jan 2013
    Location
    Russia, Nizhny Archyz
    Posts
    14
    I think you din't install your grub properly.
    I don't use grub2 (as I prefer grub).

    Latest installation of my archlinux I did so:
    1. download 2011 boot flash image;
    2. write it to flash;
    3. boot from it;
    4. make initial setup;
    5. make pacman -Syu;
    6. make system restore (as there's many bugs in archlinux added by last two years);
    7. install all needed package.


    As I've hear, last archlinux boot image is wery ugly. Considering that now archlinux can't run without systemd, I wouldn't recommend this distro to anyone.

  6. #6
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4
    My problem was probably residual data left on the hard disk after I kept reinstalling with the live-cd. I did the command "shred -v /dev/sda", after a long shred time. I was able to go through installation again, arch-chroot presented no problems, and everything loaded smoothly. I still ended up using grub2.

    Thanks for everyone's help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •