Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 36
The output you posted from the fdisk command shows only your 2GB SD card and no other drives. Since there is no information on the drive or its partitions or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190

    The output you posted from the fdisk command shows only your 2GB SD card and no other drives. Since there is no information on the drive or its partitions or filesystems there is no way to really advise you further. When you ran the command from Arch on the SD Card, did you have the 500GB drive attached?

    How did you get Arch on the SD Card. 2GB seems a little small for a full install. Are you using it as a Live CD?

  2. #12
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    First yes secound the OS is here: Downloads | Raspberry Pi search for arch....

    Can the problem be from the format of the disk? like FAT or something?
    the device light are flashing so the disk is running...

  3. #13
    Just Joined!
    Join Date
    Feb 2010
    Location
    Berlin, Germany
    Posts
    17
    By disk you mean the 500Gb drive or the SD card?

  4. #14
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    By disk I mean the HD the 500Gb drive

  5. #15
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Can the problem be from the format of the disk? like FAT or something?
    No. Pretty much any Linux system will recognize FAT, FAT32, ntfs and other windows filesystems. If you have Arch on the SD card and attached to the computer with the 500GB hard drive and fdisk doesn't recognize it, there is some other problem. Do you have any other OS on the computer?

  6. #16
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    no I dont... All I want is to be able to acess the disk directory but soon I found that I needed to mount the disk and that was when I found that the disk is not working on the linux... and I have other pc's at home and the disk works on all pc's...

  7. #17
    Just Joined!
    Join Date
    Feb 2010
    Location
    Berlin, Germany
    Posts
    17
    Did you check the filesystem type of the 500GB HD?

    Code:
    $ df -T
    Most likely it will be formatted either FAT or NTFS if you bought it recently and haven't tinkered with its filesystem. You can format it to a Linux/UNIX filesystem which probably isn't a bad idea, I experienced considerable resource usage for Linux mounting/reading/writing to a large NTFS-formatted partition.

    For that change the partition type, or rather delete the existing partition and create a new one by:
    NOTE: All commands from now on need root permission, see #

    Code:
    # fdisk -l
    # fdisk /dev/sdX
    The first command lists all drives and their sizes, with the second you can modify the particular drive.

    For X use the letter the drive is listed under /dev

    Typing m gives you the help menu with a list of options what you can do to your drive.

    Delete the current partition with d

    Write to disk with w

    Then again:

    Code:
    # fdisk /dev/sdX
    Create a new partition with n

    By default the partition type is set to Linux (Hex-Code: 83)

    Write: w

    You can also perform all modifications and write the changes as a last step that 'intermediate' write is not strictly necessary. For checking the progress of your work and status the disk/partiton is in type p.

    Then you can give it a new filesystem, EXT4 say, or whatever you like:

    Code:
    # mkfs.ext4 -L NAME-YOU-WANT-GIVE-THE-PARTITION /dev/sdX1
    Here you need to specify the partition not the phyiscal drive.


    In order to be able to write to the newly created partition, you need change the owner and thus read/write permissions otherwise you won't be allowed to as you performed all the important steps as root.

    Determine the mount point of the drive:

    Code:
    mount | column -t
    Change to the directory of the mount point, say /media

    Then change the ownership (as root of course):

    Code:
    # cd /media
    /media# chown -R YOUR-USERNAME.YOUR-USERNAME NAME-OF-THE-HARD-DRVE

    The option -R changes the ownership recursively to all subdirectories on the drive, although I'm not completely sure whether that is necessary for newly created partition, as there won't be any directories except for system folders.
    Last edited by Honeyman; 06-25-2013 at 01:47 PM. Reason: Forgot something

  8. #18
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If it works on other computers, what is the filesystem type shown? Do you have any data on the 500GB drive? The disk is also mounted by windows, usually done in the background so you don't need to do it manually. Same with a number of Linux distributions.

    df -T won't help because it only displays mounted partitions. You could try just typing 'gparted' (without quotes) in a terminal and see if it displays more than the SD. I'm not sure gparted will be installed but only one way to check is to try it.The parted command should display unmounted partitions: parted /dev/sda print all

    The above command, if parted is on the Arch install, should show all partitions. You will have to try sda, then sdb, then sdc depending upon how many hard drives, flash, SD cards or whatever you have.

  9. #19
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    Code:
    root@raspberrypi:~# df -T
    Filesystem     Type     1K-blocks    Used Available Use% Mounted on
    rootfs         rootfs     1804128 1088136    624344  64% /
    /dev/root      ext4       1804128 1088136    624344  64% /
    devtmpfs       devtmpfs    216132       0    216132   0% /dev
    tmpfs          tmpfs        44880     208     44672   1% /run
    tmpfs          tmpfs         5120       0      5120   0% /run/lock
    tmpfs          tmpfs        89740       0     89740   0% /run/shm
    /dev/mmcblk0p1 vfat         57288   18888     38400  33% /boot
    Code:
    root@raspberrypi:~# fdisk -l
    
    Disk /dev/mmcblk0: 2013 MB, 2013265920 bytes
    4 heads, 16 sectors/track, 61440 cylinders, total 3932160 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x000714e9
    
            Device Boot      Start         End      Blocks   Id  System
    /dev/mmcblk0p1            8192      122879       57344    c  W95 FAT32 (LBA)
    /dev/mmcblk0p2          122880     3788799     1832960   83  Linux
    this was the output... It only showup the SD card... the Disk drive is not here...

    If it works on other computers, what is the filesystem type shown?
    NTFS

    Code:
    root@raspberrypi:~# gparted
    
    (gpartedbin:3446): Gtk-WARNING **: cannot open display:
    Last edited by Joaogl; 06-25-2013 at 03:47 PM.

  10. #20
    Just Joined!
    Join Date
    Feb 2010
    Location
    Berlin, Germany
    Posts
    17
    Quote Originally Posted by yancek View Post
    ...
    df -T won't help because it only displays mounted partitions. You could try just typing 'gparted' (without quotes) in a terminal and see if it displays more than the SD. I'm not sure gparted will be installed but only one way to check is to try it.The parted command should display unmounted partitions: parted /dev/sda print all
    You are correct yancek, the command 'df -T' only displays mounted partitions, my mistake, I'm sorry!

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •