Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Originally Posted by atreyu wpa_supplicant never came into it for me. it was something like: Code: iwconfig wlan0 essid MY_WIRELESS_NETWORK iwconfig wlan0 key XXXXXXXXX ifconfig wlan0 192.168.1.2 netmask 255.255.255.0 up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2013
    Posts
    8

    some progress


    Quote Originally Posted by atreyu View Post
    wpa_supplicant never came into it for me. it was something like:

    Code:
    iwconfig wlan0 essid MY_WIRELESS_NETWORK
    iwconfig wlan0 key XXXXXXXXX
    ifconfig wlan0 192.168.1.2 netmask 255.255.255.0 up
    route add default gw 192.168.1.1 dev wlan0
    echo "nameserver 8.8.8.8" > /etc/resolv.conf
    That helped in a strange way but when I went to /etc directory to look for resolve.conf file (just curius what was in it) I noticed the netctl directory. In there was the following:
    Code:
    [pat@demoreal netctl]$ ls 
    ethernet-dhcp  examples  hooks  interfaces  wlan0-The Med
    I think this might be the reason "The Med" is the only network i can get on. I do not remember configuring this but I guess I did at some point after the install.

    Code:
    [pat@demoreal netctl]$ cat wlan0-The\ Med 
    Description='Automatically generated profile by wifi-menu'
    Interface=wlan0
    Connection=wireless
    Security=wpa
    ESSID=The\ Med
    IP=dhcp
    Key=mediterraneum
    I need to get back to school work but I think I will have this figured out soon.
    It is a bit strange that the password is out in the open in that file...
    the coffee house does not mater (it is on the door of the coffee house) but I wouldn't want my home network passkey to be open like that.
    I will look into this later tonight or tomorrow.

    edit: I don't remember configuring it because I didn't "Automatically generated profile by wifi-menu"
    Last edited by demoreal; 07-16-2013 at 06:30 AM.

  2. #12
    Just Joined!
    Join Date
    Jul 2013
    Posts
    8
    Quote Originally Posted by demoreal View Post
    I remember before, when I used dhclient and ifconfig that it would at least log me on first and I could even ping Google.
    This is incorrect.
    As @atreyu stated you need to first open a browser and go through the local password process,.

    The issue I had was netctl was attempting to connect at boot.
    I disabled netctl.
    I can now connect manually using the following tools:
    -------------------------
    ip llink
    iwlist
    wpa_supplicant
    dhcpcd
    -------------------------

    I set the wifi card up, scan for a network with iwlist then create a file of the network like the examples in
    /etc/wpa_supplicant/wpa_supplicant.conf

    I run wpa_supplicant in a terminal.
    Leaving it open has been helpfull to further my knowledge of networks.

    I then use dhcpcd to connect in the usual way

    when I get bored of this, I will try out netctl.
    but for now this is much more fun.
    Everything now works great.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •