Find the answer to your Linux question:
Results 1 to 2 of 2
Hey, during the installation of Arch Linux, whenever I run; mount -t efivarfs efivarfs /sys/firmware/efi/efivars (To mount efivarfs as I'm booting through UEFI after install, and need to have it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    6

    Trouble With UEFI - Can't Mount Efivarfs


    Hey, during the installation of Arch Linux, whenever I run;

    mount -t efivarfs efivarfs /sys/firmware/efi/efivars

    (To mount efivarfs as I'm booting through UEFI after install, and need to have it mounted to install a UEFI bootloader correctly.) The response to this command is;

    mount: mount point /sys/firmware/efi/efivars does not exist

    I get this message regardless of whether it's at first startup, or after installing the base system packages and such, and it's probably what's preventing me from using Gummiboot properly. For clarification, I'm not installing through UEFI, just a regular usb drive. I think it could possibly be either the directory is different on my computer for some reason, or the directory belongs to some software package I haven't installed yet.

    I'm not very experienced with AL so any help would be much appreciated.
    Last edited by Aseaxles; 10-16-2013 at 01:18 AM. Reason: Not enough information

  2. #2
    Just Joined!
    Join Date
    Oct 2013
    Posts
    6
    Update, it seems as though installing my system as if I had a regular BIOS solved the issue, I was likely running in BIOS compatibility mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •