Find the answer to your Linux question:
Results 1 to 6 of 6
Hello All, I'm currently experiencing this issue where Arch is not recognizing my USB storage devices. I get this kernel message when plugging a USB flash disk in: Code: [416184.801734] ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    23

    USB Storage Issue


    Hello All,

    I'm currently experiencing this issue where Arch is not recognizing my USB storage devices. I get this kernel message when plugging a USB flash disk in:

    Code:
    [416184.801734] usb 5-7: new high-speed USB device number 6 using ehci-pci
    But no new device nodes are created and the output of lsblk doesn't change before and after the disk is plugged in. This also occurs with flash disks from other manufacturers and external USB hard drives as well.

    I've searched around on the net, though this problem doesn't seem too common. One person said that loading the usb-storage module worked for them, but I'm using a stock kernel so I wouldn't expect that to matter. I tried it anyway and it didn't appear to change anything.

    I'm at a total loss here. Anyone got any ideas?

    Thanks in advance,
    willnoit

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Have you tried a cold reboot with the device attached to the system?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2011
    Posts
    23
    Yup. Reboot is always the first thing I try.

  4. #4
    Just Joined! nihili's Avatar
    Join Date
    Dec 2013
    Posts
    91
    does it happen with other devices also?
    is this device somehow different from others (usb2 vs usb3...)?
    is it formatted? to what?
    the output you posted is very much what my dmesg shows me for all usb devices.
    please post more output, like lsusb, mount, fdisk...

  5. #5
    Just Joined!
    Join Date
    Feb 2011
    Posts
    23
    I know it happens with two devices: a USB3 external hard drive (formatted with ext3), and a USB2 flash disk (formatted with FAT32). So, I don't think that the USB version or filesystem format make a difference. My mount looks like this:

    Code:
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    dev on /dev type devtmpfs (rw,nosuid,relatime,size=4087032k,nr_inodes=1021758,mode=755)
    run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    /dev/sda1 on / type ext4 (rw,relatime,data=ordered)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
    pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    configfs on /sys/kernel/config type configfs (rw,relatime)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    tmpfs on /tmp type tmpfs (rw)
    Though, I don't have automatic mounting configured so I don't think it'd be likely to show up here. As for fdisk, neither device shows up—a device node isn't even created when I plug one in.

    lsusb shows the "hub" devices, but does not show anything else:

    Code:
    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    I tried every USB port just in case some of them are 1.1, as seems to be the case, but the results were no different. Earlier this year I got the same USB3 external drive to be recognized and mounted, so I'm not quite sure what I'm doing differently this time. At first, I thought maybe they weren't powered, but the drive's indicator light is on, so that seems implausible. Then, I thought maybe they weren't connected to the motherboard—nope, because they show up in lsusb, and a kernel message is shown when plugging a device in.

    Next, I think I'll try booting off a liveCD and see if they're recognized in another distro; right now I'm not even sure if it's a hardware or software issue.

  6. #6
    Just Joined! nihili's Avatar
    Join Date
    Dec 2013
    Posts
    91
    the output of mount looks very strange to me. i don't understand half of it, nor what kind of arch linux install this is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •