Find the answer to your Linux question:
Results 1 to 2 of 2
Hello all, I'm new to arch but am familiar with linux but my keymaps in X (default xfce) constantly revert on reboot to 'US' when i want 'UK'. The TTY's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2

    keymap issues


    Hello all, I'm new to arch but am familiar with linux but my keymaps in X (default xfce) constantly revert on reboot to 'US' when i want 'UK'. The TTY's are fine but it is the X keymap that keeps defaulting back. If i open a terminal and "setxkbmap gb" it works.. I have also inserted "setxkbmap gb" in .xinitrc which still doesn't sort the problem..

    localectl doesn't set it permanently so these are steps I've taken:

    I have created /etc/X11/xorg.conf.d/10-keyboard.conf as follows
    Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "gb"
    Option "XkbModel" "pc105"
    Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection

    and input the same in /etc/X11/xorg.conf.d/10-evdev.conf as stated here "archbang.org/index.php?title=Setting_Your_Keyboard"

    Also /etc/vconsole.conf is :

    FONT=Lat2-Terminus16
    KEYMAP=uk

    Any help would be greatly appreciated as I'm really enjoying arch, only installed it in the last week but have taken to it very well after building up through Mandriva>Lubuntu>Fedora>Arch. I was jokingly told by others that Arch is fantastic until it goes wrong.. Although an error like this isn't enough to put me off just yet!

    Thanks in advance

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Don't know ArchBang so can't advise which conf files to edit. One workaround might be to set the cmds you use (setxkbmap gb and localectl) as Xfce session startup cmds. Another is create an /etc/X11/xorg.conf file for the keyboard.

    Have you tried this locale tutorial? Have you checked the terminal for set/edit cmds, eg 'man keyboard' and 'man locale'?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •