Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271

    Bootsplash screw-up


    Hello! So I have setup Arch just right and, as a human, I couldn't avoid screwing it up, so I tried to set up a bootsplash. I followed this 2 guides:

    https://wiki.archlinux.org/index.php/Silent_boot

    https://wiki.archlinux.org/index.php/Plymouth

    I am using a Core 2 Duo P8700 (https://ark.intel.com/products/37006...z-1066-MHz-FSB) and, because of this, I added the following to:

    /etc/mkinitcpio.conf

    Code:
    HOOKS="base udev [ins]plymouth[/ins]... [del]fsck[/del] shutdown" #Also copied and edited the necesary files to have systemd check the FS (https://wiki.archlinux.org/index.php/Silent_boot#fsck), note that I'm not using "systemd" as a hook.
    
    MODULES="[ins]intel_agp i915[/ins]" #"added to enable early KMS as detailed here: https://wiki.archlinux.org/index.php/Kernel_mode_setting .
    /etc/default/grub

    Code:
    GRUB_CMD_LINUX_DEFAULT="[ins]quiet splash loglevel=3 udev.log_priority=3[/ins] nowatchdog"
    After this, I of course regenerated the initramfs image and grub.cfg.

    Everything worked till I enabled Plymouth (meaning that "Silent Boot" works fine, but Plymouth ruins something).

    What happens now is:

    I power on, the boot splash shows up (the default grey one with a little white animation) and right after that a black screen and nothing else. I cannot switch to the CLI using Alt+Ctrl+FX, which leads me to believe the boot process didn't finish.

    Does anyone know how to solve this (I know that I can boot into the USB I used to install, mount and chroot into my root partition to change everything back and regenerate grub.cfg and the initramfs, but I want to solve this without having to give up the boot splash)?

    Any help is appreciated and sorry for the long post!

    Thread is also posted here in case anyone wants to check it out: https://bbs.archlinux.org/viewtopic.php?id=235358

  2. #2
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    -->
    A little update

    So I tried enabling and disabling single items, to narrow down the issue.. The problematic item seems to be the "splash" kernel parameter. If I enable everything ( https://pastebin.com/R6PMxuuS - https://pastebin.com/rEd6XaV3) except for that one, there won't be a bootsplash but it will take me to my DM.

    The links contain my relevant configuration files as they are now.

    I was thinking I could use another distribution like Ubuntu to see how the files are arranged.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •