Find the answer to your Linux question:
Results 1 to 7 of 7
Hey all, I seem to be having problems with the GNOME volume control restoring my settings. Everytime I boot up, the GNOME volume settings are all muted and at 0. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619

    Arch Linux - GNOME volume control problems


    Hey all,

    I seem to be having problems with the GNOME volume control restoring my settings. Everytime I boot up, the GNOME volume settings are all muted and at 0. Other than this, after unmuting them all and turning up the volume, the sound works fine. Any ideas as to why this might be?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    is just for GNOME or is it with alsa? I know when I use arch, I needed to load alsa last because it was trying to load to fast in the default position
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Well, I feel like an idiot.

    I forgot to add alsa to my DAEMONS array in my rc.conf. I never had to do that with KDE so that's probably why I forgot.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    2
    Quote Originally Posted by bryansmith
    Hey all,

    I seem to be having problems with the GNOME volume control restoring my settings. Everytime I boot up, the GNOME volume settings are all muted and at 0. Other than this, after unmuting them all and turning up the volume, the sound works fine. Any ideas as to why this might be?

    Bryan
    please reply immediately

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    2
    Quote Originally Posted by bryansmith
    Hey all,

    I seem to be having problems with the GNOME volume control restoring my settings. Everytime I boot up, the GNOME volume settings are all muted and at 0. Other than this, after unmuting them all and turning up the volume, the sound works fine. Any ideas as to why this might be?

    Bryan
    please reply immediate

  6. #6
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I am confused......
    Brilliant Mediocrity - Making Failure Look Good

  7. #7
    Just Joined!
    Join Date
    Feb 2008
    Posts
    1

    A little more complete answer

    I was having the same problem and google was making me come here.
    Well adding alsa in /etc/rc.conf, is not enough.
    I now have:
    DAEMONS=(syslog-ng network alsa netfs crond gdm)

    the trick is to set the volume right, then open a terminal with applications/accessories/terminal, then use 'su' to become root.
    Well you did set a root password at installation, did you?

    before you do the next command, you are supposed to have done:
    #pacman -Sy alsa-lib alsa-utils
    #pacman -S alsa-oss

    Ok, THE trick is mostly this:
    #alsactl store
    that create '/etc/asound.state', the current volume settings.

    That's what alsa in DAEMONS line in /etc/rc.conf will restore!

    Ok, I did not found all this by myself, I give credit to:
    ArchWiki :: ALSA - ArchWiki

    Hope this will help the next one, as it did for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •