Find the answer to your Linux question:
Results 1 to 8 of 8
Every time I boot, once it gets to the "Starting Network" part of the boot, it waits for about a minute, then displays [Failed] or whatever next to it. I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    Indiana
    Posts
    27

    Network fails at boot


    Every time I boot, once it gets to the "Starting Network" part of the boot, it waits for about a minute, then displays [Failed] or whatever next to it. I'm not sure why that happens, and was wondering if anyone could help.

    Thanks,
    Cyrano.

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Location
    Indiana
    Posts
    27
    If it's any help to anyone, the problem seems to be that the interface eth1 isn't being brought up, even though it's in rc.conf. After I've got the computer started, I have to type:
    Code:
    ifconfig eth1 up
    dhcpcd eth1
    After that my connection is up and going.

  3. #3
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Post your rc.conf and eth1 settings. Is this a wireless connection?

    Also - do you need to type ifconfig eth1 up to get it working? Or does just dhcpcd eth1 do the job?
    (tip: I like doing "dhcpcd -d eth1" to see the ip address I'm given).
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Location
    Indiana
    Posts
    27
    rc.conf:
    Code:
    #
    # /etc/rc.conf - Main Configuration for Arch Linux
    #
    
    #
    # -----------------------------------------------------------------------
    # LOCALIZATION
    # -----------------------------------------------------------------------
    #
    # LOCALE: available languages can be listed with the 'locale -a' command
    # HARDWARECLOCK: set to "UTC" or "localtime"
    # TIMEZONE: timezones are found in /usr/share/zoneinfo
    # KEYMAP: keymaps are found in /usr/share/kbd/keymaps
    # CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
    # CONSOLEMAP: found in /usr/share/kbd/unimaps
    # USECOLOR: use ANSI color sequences in startup messages
    #
    LOCALE="en_US.utf8"
    HARDWARECLOCK="localtime"
    TIMEZONE="America/Detroit"
    KEYMAP="us"
    CONSOLEFONT=
    CONSOLEMAP=
    USECOLOR="yes"
    
    #
    # -----------------------------------------------------------------------
    # HARDWARE
    # -----------------------------------------------------------------------
    #
    # Scan hardware and load required modules at bootup
    MOD_AUTOLOAD="yes"
    # Module Blacklist - modules in this list will never be loaded by udev
    MOD_BLACKLIST=()
    #
    # Modules to load at boot-up (in this order)
    #   - prefix a module with a ! to blacklist it
    #
    MODULES=(8139too bcm43xx)
    # Scan for LVM volume groups at startup, required if you use LVM
    USELVM="no"
    
    #
    # -----------------------------------------------------------------------
    # NETWORKING
    # -----------------------------------------------------------------------
    #
    HOSTNAME="logan"
    #
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES#   - prefix an entry in INTERFACES with a ! to disable it
    #   - no hyphens in your interface names - Bash doesn't like it
    #
    # Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
    #
    lo="lo 127.0.0.1"
    eth0="dhcp"
    eth1="dhcp"
    wlan_eth1="eth1 essid 2WIRE123 key 86753093142"
    INTERFACES=(lo eth0 eth1)
    
    #
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(!gateway)
    #
    # Enable these network profiles at boot-up.  These are only useful
    # if you happen to need multiple network configurations (ie, laptop users)
    #   - set to 'menu' to present a menu during boot-up (dialog package required)
    #   - prefix an entry with a ! to disable it
    #
    # Network profiles are found in /etc/network-profiles
    #
    #NET_PROFILES=(main)
    
    #
    # -----------------------------------------------------------------------
    # DAEMONS
    # -----------------------------------------------------------------------
    #
    # Daemons to start at boot-up (in this order)
    #   - prefix a daemon with a ! to disable it
    #   - prefix a daemon with a @ to start it up in the background
    #
    DAEMONS=(syslog-ng !hotplug !pcmcia netfs network crond alsa)
    
    
    # End of file
    Yes, eth1 is a wireless connection. And it should probably work without ifconfig eth1 up. However, before posting this I've discovered that it doesn't always connect when I manually type "dhcpcd -d eth1". However, it sometimes does work, so I'm guessing that there are still some issues with the fairly new bcm43xx driver that I'm using.

    Edit: I spoke with a guy in an IRC support chat for the BCM43xx driver who recommended upgrading to the 2.6.18-rc3 kernel. Haven't done it yet, but I'll try it sometime in the next few days and see how it goes.

  5. #5
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Quote Originally Posted by Cyrano
    I've discovered that it doesn't always connect when I manually type "dhcpcd -d eth1". However, it sometimes does work.
    If
    Code:
    dhcpcd -d eth1
    doesn't work try
    Code:
    dhcpcd -d eth2
    Sometimes mine switches for unknown reasons. The command
    Code:
    iwconfig
    can help to show you which one to use.

    Edit: I spoke with a guy in an IRC support chat for the BCM43xx driver who recommended upgrading to the 2.6.18-rc3 kernel. Haven't done it yet, but I'll try it sometime in the next few days and see how it goes.
    How do you currently have your wireless settings? Do you have a network profile or are you using /etc/conf.d/wireless ?

    Edit: Nevermind - I see your wireless settings are directly in your rc.conf. Make sure and set
    Code:
    lo="lo 127.0.0.1"
    eth0="dhcp"
    eth1="dhcp"
    eth2="dhcp"
    wlan_eth1="eth1 essid 2WIRE123 key ###########"
    wlan_eth2="eth2 essid 2WIRE123 key ###########"
    INTERFACES=(lo eth0 eth1 eth2)
    Before trying
    Code:
    dhcpcd -d eth2
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  6. #6
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    My wireless setup:

    /etc/rc.conf:
    Code:
    lo="lo #'s"
    eth0="dhcp"
    eth1="dhcp"
    eth2="dhcp"
    INTERFACES=(lo eth0 eth1 eth2)
    
    DAEMONS=(... !network ...)
    I have ! before network to prevent it from starting at boot.

    /etc/conf.d/wireless:
    Code:
    #HOME
    wlan_eth1="eth1 essid HOME key #'s"
    wlan_eth2="eth2 essid HOME key #'s"
    
    #SCHOOL
    #wlan_eth1="eth1 essid SCHOOL key #'s"
    #wlan_eth2="eth2 essid SCHOOL key #'s"
    After boot I give the command dhcpcd -d eth1 (or eth2) and it starts up the "home" connection. When I goto school I simply comment the home settings and uncomment the school ones.

    This seems to work best for me - as starting the wireless network at boot proved to be a real pain. Perhaps you're having a hard time loading the network at boot because your adapter keeps switching from eth1 to eth2 as mine does.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  7. #7
    Just Joined!
    Join Date
    Jun 2005
    Location
    Indiana
    Posts
    27
    My adapter has been staying at eth1, I think it could just be some weird issue with DHCP and the BCM43xx driver. I'll find out if I ever take the time to get the latest and greatest kernel.

    Out of curiosity, what sort of wireless card do you have? (What module does it use?)

    Also, if you want to prevent the ethernet from changing from eth1 to eth2, I came across this in the wiki a few days ago: Mixed up devices.

  8. #8
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Quote Originally Posted by Cyrano
    My adapter has been staying at eth1, I think it could just be some weird issue with DHCP and the BCM43xx driver. I'll find out if I ever take the time to get the latest and greatest kernel.
    Did you ever check this section of the wiki or this list?
    Quote Originally Posted by Cyrano
    Out of curiosity, what sort of wireless card do you have? (What module does it use?)
    Orinoco - it's loaded in the kernel.
    Quote Originally Posted by Cyrano
    Also, if you want to prevent the ethernet from changing from eth1 to eth2, I came across this in the wiki a few days ago: Mixed up devices.
    Nice - I'll give that a go.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •