Find the answer to your Linux question:
Results 1 to 10 of 10
This is my first time with Arch, try to help this Arch n00b Installed it without problems, used pacman to install some things, changed config files to get my network ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064

    Network at boot


    This is my first time with Arch, try to help this Arch n00b

    Installed it without problems, used pacman to install some things, changed config files to get my network to work, it works but now when I want to start networking I need to use "netcfg --select" I don't know how to add networking to the init scripts, I am used to have init scripts in /etc/init.d

    I can't load gdm although I installed it with pacman, also installed fluxbox but fluxbox complains about no x server

    Thanks in advance
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Hi Pablo

    Which distribution are u using when getting this, Gentoo or Slackware?
    Regards

    Andutt

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Arch really
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Edit /etc/rc.conf
    Go to the Networking section and add to the INTERFACES= section. You'll have to set them to dhcp to us that.
    Code:
    # -----------------------------------------------------------------------
    # NETWORKING
    # -----------------------------------------------------------------------
    #
    HOSTNAME="vaio"                                                 
    #
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES
    #   - prefix an entry in INTERFACES with a ! to disable it
    #   - no hyphens in your interface names - Bash doesn't like it
    #
    # Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
    #
    lo="lo 127.0.0.1"
    eth0="dhcp"
    eth1="dhcp"
    eth2="dhcp'
    INTERFACES=(lo eth0 eth1 eth2)
    #
    For me, eth0 is wired and eth1/2 are wireless. To have a connection auto-start at boot add "network" to the DAEMONS= at the bottom of your rc.conf:
    Code:
    # -----------------------------------------------------------------------
    # DAEMONS
    # -----------------------------------------------------------------------
    #
    # Daemons to start at boot-up (in this order)
    #   - prefix a daemon with a ! to disable it
    #   - prefix a daemon with a @ to start it up in the background
    #
    DAEMONS=(syslog-ng iptables network netfs crond alsa)
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  6. #5
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Thanks, I now have a problem starting gnome (give up with fluxbox), it says I don't have fontconfig althought it is installed, any ideas?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  7. #6
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Where do you get the error? When you startx?
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  8. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    In the console from where I launched startx, twm loads and some xterms but the when I try something like "fluxbox" or "gnome" it complains about problems with fontconfig and doesn't start,
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  9. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1
    Are you trying to start fluxbox/gnome directly from the CLI? You need to add the command for whatever WM you want to use to your ~/.xinitrc file, or to an xsession. I have never used the xsession, so I can't help you on that, but the .xinitrc is extremely simple to use. If you don't understand something, a quick google for xinitrc should help. If you are already doing this, just ignore this message and let the next, more experienced, person help you out.

  10. #9
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1

    Unhappy

    Quote Originally Posted by benson2788
    Are you trying to start fluxbox/gnome directly from the CLI? You need to add the command for whatever WM you want to use to your ~/.xinitrc file, or to an xsession. I have never used the xsession, so I can't help you on that, but the .xinitrc is extremely simple to use. If you don't understand something, a quick google for xinitrc should help. If you are already doing this, just ignore this message and let the next, more experienced, person help you out.
    what does the "VM" mean? I had lookd at wiki, but i did not understand it.

  11. #10
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Windows manager
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •