Find the answer to your Linux question:
Results 1 to 4 of 4
I ran pacman to update my system the other day and ran into some problems afterward. First, my system overheated so I had to restart, after restarting, GRUB gave me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9

    Unhappy Pacman and miscellaneous problems...


    I ran pacman to update my system the other day and ran into some problems afterward. First, my system overheated so I had to restart, after restarting, GRUB gave me "Error 15: File not found." I resolved this but now I still get:
    No filesystem cound mount root, tried:
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

    I'm not sure how to fix this but in the mean time I was able to boot into Linux via an install cd and by typing "arch root=/dev/sda2 noinitrd ro". After getting back into Arch, I did a pacman -Suf to finish installing the updates, which didn't complete from before. However, my ethernet adapter no longer shows up. I tried /etc/rc.d/network start and it just gives me ":: Starting Network [FAIL]".

    My system is pretty jacked up after doing pacman but if anyone can help me resolve some of this, it'd be greatly appreciated!

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    For the networking, it could be one of many issues. Check your rc.conf and make sure the network settings are good. Also, check /etc/conf.d/ and make sure the settings are okay with some of the scripts there (network, dhcpcd...).

    Did you upgrade any network related packages? You could downgrade some of them.

    Have you modified anything else or did you just update?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Just as a recommendation, you should
    Code:
    pacman -Syu
    to upgrade, or
    Code:
    pacman Sy app
    to install.

    Only force an install/upgrade if you absolutely have to.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2
    The issue seems to be that you havent read the new upgrade guide. If your on a Intel based chipset you need to edit menu.lst and change all hda devs to sda. then in fstab do the same accordingly. Just a note read before you update to avoid similair issues!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •