Find the answer to your Linux question:
Results 1 to 3 of 3
hi at all, i'm new in this forum. i'm writing for help to enable audio 5.1 on my archlinux. first of all, i have searched on google/linux and here but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Location
    Molfetta (BA), Italy
    Posts
    2

    Question enable audio 5.1


    hi at all,
    i'm new in this forum.
    i'm writing for help to enable audio 5.1 on my archlinux.

    first of all, i have searched on google/linux and here but without great results.
    on this page i have found a wiki @Italain:
    Hardware supportato - Linux@P2P Forum Italia

    following this wiki i have created a ~./asoundrc with this line
    pcm.!default {
    type plug
    slave.pcm "surround51"
    slave.channels 6
    route_policy duplicate
    }

    restarted x i see this error:
    Sound server informational message:
    Error while initializing the sound driver:
    Unable to set interleaved!
    The sound server will continue, using the null output device.

    i have changed somethink with alsamixer but really i don't know what i have changed and i don't know how to turn back to default settings.
    i'm not so expert of this kind of settings. help me please.

    finally something that could be usefull:
    [dax@feeder ~]$ lspci | grep audio
    00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
    [dax@feeder ~]$ lsmod | grep snd
    snd_intel8x0 28700 1
    snd_ac97_codec 95780 1 snd_intel8x0
    ac97_bus 2432 1 snd_ac97_codec
    snd_pcm 69124 2 snd_intel8x0,snd_ac97_codec
    snd_timer 19076 1 snd_pcm
    snd 44516 6 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
    soundcore 6368 1 snd
    snd_page_alloc 7816 2 snd_intel8x0,snd_pcm


    thanks for the time spent reading this.
    bb

  2. #2
    Linux Newbie Tutku's Avatar
    Join Date
    Jul 2007
    Location
    Izmir / Turkey
    Posts
    167
    for returning the default settings, you can delete ~/.asoundrc file.

    with alsamixer, you only change the sound levels, so it is not so important, and after changing with the alsamixer, you have to use
    Code:
    alsactl store
    command to save the new settings, if you didn't use this command, your alsamixer still has default settings.

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Location
    Molfetta (BA), Italy
    Posts
    2
    thanks man, i have tryed this way but don't have solved my problem.
    since i have written this post i've made something.
    also i've written a post into archlinux forum, here:
    Arch Linux Forums / kit audio 5.1 problem with speaker-test and kde

    could /etc/asound.state be usefull to help me?
    if need is here: nopaste: pastebin with syntax highlighting

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •