Before Ill go to my problem Ill tell how our network looks.
So you have an idea what the problem is.

There is a Debian 4 Stable box that has ip 192.168.42.112
That Debian box runs OpenVZ to emulate 10 Gentoo Boxes.
With the IP Range 192.168.1.1~10
Well 192.168.1.1 is the App Server. (It has Firefox on it but not a DE)
192.168.1.5 is the Desktop Server (It only has X11-org and xfce running on it)
When I am on my WinXP Laptop I have to connect to the xfce desktop and then run firefox.
So, Basicly I need to do the following:
Me (192.168.42.105) -> Debian (.42.112) -> VirtualDesktop Server (.1.5) -> Virtual App Server (.1.1)
So, What I did was I used Cryptcat to make a tunnel to the Desktopserver from the Debian.
So, I can connect to .42.112:5900 if I want to get .1.5:5900.
In the VNC Session I run the command in a Terminal:
ssh -2 -c blowfish -X robin@192.168.1.1
to connect to the App Server.
I get connected fine.
And then I enter Firefox.
And then I get a problem
I get the following BadAtom error msg.
When I googled that I found out that I had to change a setting in /etc/ssh/sshd_config to set X11Forwarding yes

Well, I did that.. And I restarted the ssh server.
I reconnected.
Same error.
After googling more I found out that I might had to enable the Y flag.
Well, done..
I got the error bad display.

And, now the funny part...


In the time I was typing the message Firefox showed up in my VNC Screen. (It took 30m minutes to load firefox..)
It works.. but It does generate the error msg that It cant find a screen..
I am not going to waste the time I have used to type this msg.
Ill post it in the Coffee place.
I hope somebody has a use for this story..


Cheers,
Robin