Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
6 days after my previous post*, here is how the experiment of installing Linux music distros on my HP went: Initially, I was partial to Dyne:bolic for its noble act ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    Talking Adventures in Linux MIDI


    6 days after my previous post*, here is how the experiment of installing Linux music distros on my HP went:

    Initially, I was partial to Dyne:bolic for its noble act of putting a cute dark skinned babe on its desktop. (And you thought I'll wax poetic how it's a studio for the world's oppressed. 1:0. ) As a boot OS, Dyne:bolic ran like lightning. It flashed a bunch of branches then smashed into the ground seconds later, leaving only a black hole on my screen. Interesting, it loads fine in VMWare. Maybe it sensed the capitalist oppressor in me? I have a significant capital invested in junk blondes I like to oppress from time to time. I copied the Dyne folder to the HD next as the manual suggests and rebooted it twice. Arnold Palmer eat your heart out, I got a hole in one, twice in a row again. The manual says, "This is Rasta Software" Maybe it isn't ALSA that makes it play music to the users, but THC? The world liberator next door still strums his protest songs on a guitar; probably because it doesn't require GRUB editing for an Emaj7. OK, I'll try Ubuntu Studio then.

    At first run, Ubuntu Studio 9.0.4. froze right at the splash screen. (top left image at: http://www.s204809728.onlinehome.us/...UbuntuOnHP.jpg). Ah well, let's not get prejudiced by reality, I launched Studio again. This time I got past the splash screen; by golly, some of the desktop artwork is drop dead gorgeous! I hooked modules together by the book and Studio made sound! It was choppy and mangled so I started tweaking and clicking JACK Control's knobs to tune in "Lumphrr... schwakawaka... pitzblblngbl... gwurblyquexlaurherpppp... BARODOBODOM!... queahrlyprtlyprtly..." kinda like my grandpa tweaking his radio's knobs in WW2 trying to find BBC while the town was being bombed. I resized JACK Control's windows to see all the parameters, which lead to the photo in the top right.

    I started Studio the third time. I resized JACK Control's windows before turning JACK on. I pulled out all the stops, setting it almost fully to "not nice", etc; with a CPU monopoly like this, XP would crank out 120 channels of audio and MIDI on this HP already. The OS began complaining again that Alsa couldn't commit any memory (sounds like an auntie with delirium tremens) and after a series of X-runs, Jack X-pired from all the X-citement too (see bottom picture). This is when I recalled the remark I read in Red Hat Magazine from the coders of Agnula, the first music distro. "We wrote the software but we don't really know how to use it because we're hackers, not musicians." Well yeah, if you never try to make music with these, they work grrrreat! As far as an actual musician with a production background installing and using a Linux distro, you just read the results.

    All in all, to correct the statement in my previous post, the weak link in running OSX, XP and Linux together for music on a single computer is not ALSA and JACK in VMWare. It's ALSA and JACK in anyware.

    http://www.linuxforums.org/forum/ubu...tml#post737360
    Last edited by waterhead; 12-05-2009 at 07:24 PM.

  2. #2
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    64 Studio 2.0

    The next music distro I tried for a spin is 64 Studio. (What's the 64 exactly? I didn't check. Maybe a 69 after tax. ) I put the Live CD in my HP's tray, and booted from it; a nice splash screen appeared. Yay, a promising start, like when your blushing movie date asks what you like for breakfast. I pressed F2 and enjoyed the view of long lines of code scrolling down on my screen how things like SCSI devices my HP doesn't have are being initialized.

    And then... Linux's black screen of total relaxation. (No blue screens of death, of course.) Absolute silence. One could hear a penguin poop. (They don't fly.)

    Hmm, maybe the CD took the wrong turn? I restarted 64 Studio choosing the "live-failsafe" boot. It worked! It brought me fail-safely black to the same black screen. All right, I got the picture what I'll see when I kick my oxygen habit. Now how do we get this baby to make noise?

    For the third try, let's see if 64 Studio works better if I install it to HD, instead.
    I chose "installgui".
    "Could not find image."
    I chose "install"
    "Could not find image"
    I chose "expert"
    "Could not find image"
    I chose "expertgui"
    "Could not find image"
    Not a single image. Like a command-line version of Playboy. Maybe this distro was Live but something did it in? They call its console "terminal" already, don't they. I tried to go on booting without watching the system messages, it led to the same Linux By Night dusktop.

    All in all, the only sound yours truly musician got out from 64 Studio Live is a "schplurrttt!". That's what the HP says when I push its power button.

    Tune in the next time when I'll try to team up with JackLab.

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    JackLab Audio Distribution (JAD) 1.0

    The first thing I noticed on the JackLab splash screen (first image at http://www.s204809728.onlinehome.us/images/JackLab.jpg) is that it's based on Suse, my first Linux encounter of ten years ago. My, it's a small world! Let's see if (unlike yours truly) Suse grew more mature.

    I started with the Firmware Test. It came back negative. That is, I got the Linux black screen of Dracula's solarium. Either that or (darn GRUB!) master-booting did make me blind. After the restart I launched the installer; as soon as it spotted me it threw its "Install" buttons away. (second image) Unfazed, I pressed on with [Enter] instead, ignoring the warning, "Abandon all hope, ye who [Enter] here." In Suse, the penguin is a chameleon. (Machine translation at work!) Things went smoothly, until Hardware Setup set up a pattern on my screen hardware. (third image) I waited ten minutes to see what's next, maybe a chameleon will crawl on it?, but none appeared. They are all at the Boy George concert.

    After the restart, I chose the Failsafe mode to fail safely. It launched an installer resembling Atari's Pong (fourth image). *Now* we reached my level of Linux proficiency! Suse asked for an assword, so I entered hee-hah! (fifth image). She offered to rewall my HP, (sixth image) and begged me not to release. (seventh image) What is this, tantric Linux? Before I could sing "Root Operator" (Sade), SuSe threw the brick pattern in front of me again. Yeah, that's my lot; the young sow wild oats, the old grow sage.

    I rebooted, chose Installation, then Safe Settings. It loaded the Linux black screen of Henry Ford color swatches. What's up, Suse honey, you're out of bricks too? I selected the last remaining option, "Rescue System". It must have really ticked her off, because she began "canning LVM volume groups" and "hecking the file systems". (last image). After successfully canning my file system to heck (I suppose), Suse stopped without saying a word anymore. Ha ha Susy, I got you on the Turing test now. A real woman won't stay speechless.

    Though I haven't seen Suse work for music (or anything else) for a second, I can't dispute its consistency. I couldn't install it in 1998, and I still can't install it in 2008. This makes it even safer than Ubuntu: SuSe does away not just with root but the users as well. By its withholding of the final installation step, Suse is Tantric Linux at its finest. If anyone has a copy of Studio-To-Go I could borrow for a test spin, please send me a message. Until then, tune in next time when I'll try - Artist X.
    Last edited by waterhead; 12-05-2009 at 07:26 PM.

  4. #4
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    556
    Actually, what do you want?
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  5. #5
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    I'm a musician going through the Linux distros for music to find one that works well. I decided to publish my experiences for other musicians (and the distro programmers, if they care) because it might be useful (for comparison, troubleshooting or whatever)

  6. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    ArtistX DVD 0.7

    I never heard of ArtistX before, so I was pleasantly surprised when the "Live" disc loaded the program without any glitch. So far, a first! Weird how the distro resembles Ubuntu, even the logo... crikey, this IS Ubuntu 8.10! But an elegant, deluxe 8.10, with tons of software not included in Ubuntu Studio 9.0.4., like Rosegarden, PureData, Cecilia/Csound, LMMS, etc., and 9.0.4.'s 'root' login annoyances uprooted. This is the first distro to which I didn't have to add soundfonts; a telltale sign that the writer of this distro *did* test many of the music apps.

    Hard drive installation completed without a single snag; the installer even imported my Windows XP desktop picture when told so. (Picture 1 at ArtistX Screen Shots) The programmers must have spent quite a few sleepless nights making sure ArtistX will offer a pleasant experience; it shows. (Probably on them too.) JACK launched without issues; starting Qsynth gave it the xruns, but they both continued. Next I launched the prima donna of Linux sequencers, Rosegarden, for a real stress test. (Not the computer's, mine.)

    "Brrrrt!" ""System timer resolution is too low!". (Picture 2, same URL) Aha, our beloved algorithmic complaints generator is ready. I opened a MIDI file in it, and Rosegarden promptly garbled its playback. (Picture 3) Muse played the same MIDI file just fine. (Picture 4) So did Timidity and MoviePlayer and my Noklia' cell phone. I could have guessed from the name, Mom's rosegarden has a few bugs too. (That is, "features." She doesn't use feature spray.)

    I moved on to seek easier gratification at the 138 other apps on the "Sound & Video" menu for now. Cecilia is a graphic interface for the famous CSound, a sort of ancestor of my Kyma Capybara. Its GUI stumped me at first. A gray rectangle with a mail slot? (Picture 5) After a while I grokked, the program haven't crashed, only a successful brain donor set its text color to match the background's. LMMS is another surprise: it's nowhere on ArtistX's menus, but when I entered "lmms" into the console, the installer appeared. I read since that there are 2500 programs lurking in ArtistX. If true (I haven't found a list), that's 10 times the number appearing on the menus. Imagine if Beethoven had access to a thousand composing programs... he would have written 3 short sonatas in his whole life.

    Having one's work apps preinstalled does save a lot of time, of course. Just try to compile and install a tempting item like Anthem (Picture 6) or Wired (Picture 7) yourself. Following instructions to the letter, I couldn't even compile a single source. Some cannot even be downloaded: when I visited Waon, a Pogo ad covered the page and just wouldn't scram. (Picture 8.). Now imagine an app like the highly promising Strasheela, which presumes you'll succeed to compile not even one item but - four? As probable as a Miss Pope Universe contest. All in all, ArtistX will be a very handy distro in any Linux musician's toolkit for its polished interface and its app selection. It's so far the best off all the ones tried; programmer Marco Ghirlanda is doing a great job.

    Tune in the next time when I'll try to find a Rosegarden without thorns in - Pure-Dyne.
    Last edited by waterhead; 12-05-2009 at 07:27 PM.

  7. #7
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    Pure:Dyne leek & potato

    The first thing one notices about PureDyne is minimalism. Even the desktop mascot is a little black mouse. (Mickey's sister?) The distro loads with something like 3-point type text (Picture 1) How you increase the font size if you cannot decipher a word? On the main menu select "Krtskbl", (or so, the 6th item) then "Drngg mrkprtsk" (the 17th). Next in the "Thblbb" tab, click "Bwrwr 3" and increase "3" to "14". Et voila, now you can read what's what. Repeat every time you launch Pure-Dyne since as it won't remember a thing tomorrow. (An ideal date.)

    Even after one increases the font size for the mousktop, some applications still launch with tiny lettering. (Picture 3.) Perhaps as a remedy, the sound apps menu, with lines like XavTV or Zynaddsubfx does look like an eye chart. And Xfce... (bless you!)... how about an easier name, like, Atchoo? Oh wait, that's Apache on Gentoo.

    The good news is that the minimalism carries over to the audio problems too: Rosegarden played my MIDI file and produced sound without a single xrun whatsoever! (Picture 4) I nearly threw my brain away, could I only find one. I haven't seen this on any distro yet. Yess! The RG plugins (Wsynth, Ysynth, Hexter...) ran at full steam, I could record and play back MIDI keyboards, it was a whole new experience, like listening to acoustic techno.

    PureDyne's entire menu of audio programs fit into picture 5 and 6: it focuses mostly on Rosegarden and Ardour, and items that plug into them. As it is mainly a "Live" disc distro, installing any additional software will be a challenge. Still, if you don't care to explore new musical apps, approaches, and app roaches (you know, the dang outside stuff that won't compile) the current setup might be all you need to create the next top 40 hit song. Besides talent and a huge magnifying glass.

    Happy Thanksgiving and tune in the next time when I'll try - Musix.

  8. #8
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    Musix 1.0, Agnula, AudioSlack, StudioToGo, Turn-Key Linux Audio, M-Dist, OpenMamba

    Booting Musix 1.0 felt like a trip to an amusement park: I had to prod my HP's restart button like the flipper switch on a pinball machine. My first boot ended at Picture 1 (k-ching!...plonkk), the second, failsafe boot careened through Pictures 2, 3 and 4. (chingding, bingbiling... plonkk). For the third boot, I selected "expert" (blingdilingg... "Extra Balls!"... badabingg... "Next level!") and this extra ballsy lie of being an expert got me to the login screen. (Me an expert, yeah right... the bash shell gives me only a ˘ for a prompt.)

    Musix's desktop starts with a neat intro: a window that plays music, and a mixer with faders to push (or, "twiddle", as Musix says) until you hear it. A brilliant idea! You twiddle around till Musix sings the high note. (If it doesn't, you can twiddle til you do.) I must have twiddled Musix with real passion because it performed a daring tango mortale. (Or some such latin dance. I can barely tell a fandango from a lumbago.)

    The distro comes with a healthy selection of softsynths and other apps (Picture 7) but starting JACK produced xruns before I even launched any of them. (Picture 8. ) Once running, Muse or Rosegarden didn't produce any sound. What's up, did I get the Library Edition? I tried Timidity++ next, it played my MIDI files fine with sound. It's amazing how Timidity always works, even without JACK. Could we build music apps on top of Timidity instead, please? I tried to install the distro to HD to shake the other apps back to life, but it only led to Linux's black screen of toner box sneeze.

    No biggie, I thought, if Musix won't install to HD, I'll simply boot again in expert mode. Was I naive like a flute player to a deaf cobra. No pasarán!... the second time, hardware autoconfig led to Linux's black screen of Eine Kleine NachtMusix. Humm, okay... it was fun till it lasted. The distro shows promise, but it's hardly an autopilot ride unless you moonlight as a kamikaze. To be fair, I got still farther with Musix than with the following music distros:

    Agnula - defunct, web site gone, no reply to email
    AudioSlack - defunct, web site a billboard ad now, email bounced
    Demudi - defunct, web site gone, superseded by Debian Multimedia Project
    Studio To Go! - defunct, web site gone, no reply to emails
    Turn-Key Linux Audio - defunct, removed from site, no reply to email
    M-Dist - the CD loaded OK, but distro couldn't get its JACK up (old age, perhaps?)
    OpenMamba - the splash screen led straight to Linux's black screen of lenscap photofinish. Reboot in debug mode reached the "host added" line, then faded back to Linux's During Dark Screensaver. I guess this is what a mamba is like? From inside.

    Tune in next time, when I'll try - AV Linux

  9. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I've been sort of following you on this. I have an older version of 64studio installed. It took a bit of tweaking, but it seems good now.

    I also installed Fedora, and upgraded it using the CCRMA repository. At first it seemed real good, but the constant upgrades from Fedora are breaking things. So I should have either disabled the Fedora repositories or disabled updates completely!

    I also was wondering if this is the correct section to have this thread in. I could move it to a more appropriate section, such as the Gaming / Games / Multimedia / Entertainment section.


    Edit by ozar: hello, waterhead, I've moved this back to the Coffee Lounge since it's more of a blog-type thread than it is a help request.
    Last edited by oz; 04-13-2010 at 06:19 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Although the Planet CCRMA web site doesn't mention it, I see Fedora 12 listed in their repository.

    Index of /planetccrma/mirror/fedora/linux/planetccrma/12

    When you try CCRMA, make sure you add the correct address to the repository.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •