Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 39
romster always had the best ports for some of my apps. IceWM included. Keep us posted, Jonathan!...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    romster always had the best ports for some of my apps.
    IceWM included.


    Keep us posted, Jonathan!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  2. #12
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by Jonathan183 View Post
    Installed and adding apps at the moment.
    Cheated a bit ... running grub2 from my Arch setup & pinched .config for kernel from my Gentoo setup.
    Hi Jonathan183! That's the easiset way if you already have a distro running on the same machine. I usually grab my old .config and use it to compile since the hardware is all the same.
    Also installed all packages rather than just core. Installed to an ext4 partition but when I tried to boot got error saying CONFIG_LBDAF needed to be enabled (went back into kernel config and enabled it and recompiled and the system boots).
    Ran into that too and just enabled all the file systems to be on the safe side.
    enabled contrib and added romster to /etc/prt-get.conf so I now have icewm (han did not seem to work)
    prtdir /usr/ports/contrib
    From my prt-get.conf, here are the ports that have been working best for me:
    Code:
    prtdir /usr/ports/core
    prtdir /usr/ports/opt
    prtdir /usr/ports/xorg
    prtdir /usr/ports/contrib
    prtdir /usr/ports/gnome
    prtdir /usr/ports/kde
    prtdir /usr/ports/sepen
    prtdir /usr/ports/tilman
    prtdir /usr/ports/vico
    Romster does a good job but for some reason his are either available or not. I did use Romster for icewm but it's really easy just to nab the sources from the site and compile the latest.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #13
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Install went smoothly but have run into a real head scratcher.

    /dev shows no partitons for sda*. My root partition is /dev/sda7 but it doesn't show up either. fdisk -l returns nothing. I was going to edit fstab to point /home to /sda6 but when I try mounting it, it says it doesn't exist. I'm using the same .config from last CRUX install. All partitions show perfectly in /dev when I boot back in to old CRUX install. Anyone have any ideas?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #14
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,211
    What driver are you using in your new kernel? You need to use PATA/SATA to get sda names. With the old ATA driver you get hda.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  5. #15
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by hazel View Post
    What driver are you using in your new kernel? You need to use PATA/SATA to get sda names. With the old ATA driver you get hda.
    Hi hazel. I've had PATA/SATA support in my .config for a while and have always got sd* in previous CRUX installs. Interestingly, when I do "df," it shows /dev/sda7 but not the other partitions. I had jaeger helping me on #crux and he said it was one of the strangest things he's seen. /var/log/boot shows the other partitions are seen as sda* but none of them show up in /dev. I even powered on my external hard drive after booting 2.7 and it found its partitions and showed them in /dev.

    I'm going to re-install to see if I run into the same problem again. Thank you for your input.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #16
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    I have hda and sda with IDE and genuine sata so my config is a little different.
    Since my last post have ...
    Set keyboard layout to gb using info from Beginners' Guide - ArchWiki
    installed openoffice straightforward using prt-get depinst openoffice
    for claws-mail ended up downloading from Download libEtPan! - a mail library from SourceForge.net
    and copying into /usr/ports/contrib/libetpan as prt-get depinst claws-mail failed to download the file
    also gnupg failed to build (footprint failed - error message) ... which is where I am up to at the moment ... I'll get round to sorting that later ...

    btw - had a quick look through my boot log and no mention of raid ... not sure if that helps

  7. #17
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    This is so weird. I did a complete re-install and still, my partitions do not show up in /dev but partitions on external drive do. There must be something different in the kernel that needs adjusting but I'm at a loss to know at this point.
    Code:
    RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)
    Suggestions very much appreciated.

    @ Jonathan183, you can use the "ignore footprint" option to get around it...
    Code:
    prt-get depinst -if gnupg
    If it won't install by regular means. You're leaving me in the dust on this install!
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #18
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by Dapper Dan View Post
    Code:
    prt-get depinst -if gnupg
    If it won't install by regular means.
    Thanks Dapper Dan that worked ... just does not feel like the right thing to do to force things and ignore error messages - but it's one of the FAQs

  9. #19
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by Jonathan183 View Post
    Thanks Dapper Dan that worked ... just does not feel like the right thing to do to force things and ignore error messages - but it's one of the FAQs
    It does feel strange but I've been doing it for years when I run into it or -im for ignore midsum and haven't had any problems yet. *knocks on wood*
    Linux Mint + IceWM Registered: #371367 New Members: click here

  10. #20
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Well, I did something crazy. I borrowed the .config from an Ubuntu 10.04 box and used it to compile the kernel in CRUX. Even though I have a very bloated kernel for my system, my partitions are at least showing up in /dev. Now I know my problem has to do with kernel configuration so I must figure out what the difference is and turn that part of it on or off...
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •