Find the answer to your Linux question:
Results 1 to 4 of 4
Hello everyone. I have a Viliv N5, that ships with Windows 7 Starter. I would like to make a backup of its recovery partition in order to install linux on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    3

    [SOLVED] How to access a 0x12 system recovery partition


    Hello everyone.

    I have a Viliv N5, that ships with Windows 7 Starter. I would like to make a backup of its recovery partition in order to install linux on it.

    The problem is, I can't access the contents of the partition.

    The fs in the partition is ntfs. It's id is set to 0x12 or "Compaq Diagnostics" at boot up by the windows bootloader, so it stays hidden from windows (it looks like unformatted space with no fs type or drive letter).

    I booted Ubuntu (also Puppy and Fedora) from SD and tried changing the fs type with c/fdisk but I still can't mount it (mount thinks it's not a valid ntfs). gparted sees it as an unknown fs. I also changed it with window's diskpart and was able to assign it a drive letter but windows still sees it as unformatted space.

    Any ideas? There must be some way to access the data in that partition. Btw, I know it's still there because I restored the windows installation from it after trying all of the above, just to make sure it's OK. The system recovery utility (AMI Rescue) boots into an XP installation environment (sadly, no recovery console) so there's really nothing exotic going on in there, it's an ntfs that's not recognised as such by anything except the windows bootloader.

    Er. And I'm trying to avoid editing that bootloader 'cause the documentation for it looks a bit confusing O.o So any other suggestions?

    Thanks in advance. And happy holidays!

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    The file system on the Compaq Diagnostics partition may
    not be NTFS. It may be FAT32 or even FAT16.

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Posts
    3
    I tried fat 32 also (in fact, two or three of them), but at that point I wasn't keeping track of exactly what I was doing anymore so I might have missed something. I'll try again (and try fat 16 also).

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    3
    Phew! That was close!

    I tried setting the partition id to every likely partition type in turn from windows' diskpart, so when I got to 0x0f (extended win95) it gave an error and lost the OEM recovery partition, and the small windows 7 recovery partition next to it.

    I tried with fdisk but apparently you can't turn an extended partition into a primary one and v.v. Well, you can... in windows... :facepalm:

    The good news is I managed to recover both partitions with Easeus and now I can see their contents- and their file types, at last. The recovery partition was indeed fat 32, so I still have no idea why I couldn't access it just by changing its id, because I did try it.

    Oh well, at least I can now copy my backup files and install a new OS. Thanks rcgreen, for the help.

    How do you mark a thread as answered/ solved?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •