Find the answer to your Linux question:
Results 1 to 1 of 1
Note: I'm not sure how this ended up in the Coffee Lounge. I meant it to be in the Gentoo forum, but seem to have messed that up. I recently ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191

    [SOLVED] Sharing my NXServer journey


    Note: I'm not sure how this ended up in the Coffee Lounge. I meant it to be in the Gentoo forum, but seem to have messed that up.

    I recently updated my system and my nxserver-freeedition stopped working! After several days of failed attempts I just got things going again. Therefore I wish to share my experience so that someone else may be helped out.

    Initial Problem:

    When attempting to start the nxserver (/usr/NX/bin/nxserver --start) I would get an error message which stated that a perl library could not be found. In fact, a whole bunch of perl libraries were nowhere to be found as far as nx was concerned. I was able to manually point most of these one by one getting a new failure.

    Finally I was stumped by the fact that libcrypto-0.9.8 could not be found. Trying to re-emerge nx, nxserver, nxclient and the like did not fix anything. Since I use gentoo I figured revdep-rebuild could help, but no dice!

    As it turns out, the libcrypto issue stems from an openssl upgrade. I tried to use revdep-rebuild -L lib{crypto,ssl}.so.0.9.8 but no dynamically linked packages were found.

    Solution to the initial problem:

    After getting my system up to date I needed to issue the following in order to re pull in the 0.9.8 package:

    Code:
    emerge -1 openssl:0.9.8
    Great! except, when I try to do /usr/NX/scripts/setup/nxserver --install to get things right again, it fails because it couldn't find Linux.so. What was Linux.so? I couldn't find it anywhere.

    Solution to the Linux.so problem:

    Code:
    emerge nxnode
    Now, I could run

    Code:
    /usr/NX/scripts/setup/nxserver --install
    /usr/NX/scripts/setup/nxnode --install
    /usr/NX/bin/nxserver --start
    Then it was just a quick reset of my dsa key to the default value in my client and I got really close to starting. I hit the following error:

    Code:
    Info: received data in out channel from NX Node: 'NX> 618 Your evaluation period has expired. Please visit 
    NX> 618 the NoMachine Web site at http://www.nomachine.com/ 
    NX> 618 to acquire a valid subscription. 
    ' (NXNodeExec) 
    Info: received data in out channel from NX Node: 'NX> 690 Bye. 
    ' (NXNodeExec) 
    Info: NX Node out channel was closed (NXNodeExec) 
    Info: Removing not recognized buffer from stdout:[] (NXNodeExec) 
    Info: NX Node err channel was closed (NXNodeExec) 
    Info: closing nxssh's in, out, err FDs (flagfinished is: 0) (NXNodeExec) 
    Error: no 'CONNECTED' message from NX Node (NXNodeExec) 
    ...
    You have got to be kidding I said. Finally I realized that the following was necessary:

    Solution to the License issues

    Code:
    emerge --unmerge nx nxclient nxnode nxserver-freeedition
    rm -rf /usr/NX/*
    emerge nxclient nxnode nxserver-freeedition
    Then I could start the service and connect....


    Summary of commands that should work:

    Code:
    emerge -1 openssl:0.9.8
    emerge --unmerge nx nxclient nxnode nxserver-freeedition
    rm -rf /usr/NX/*
    emerge nxclient nxnode nxserver-freeedition
    Whew! I hope someone else is helped by this
    Last edited by sdimhoff; 01-14-2011 at 06:30 PM.
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •