Find the answer to your Linux question:
Results 1 to 2 of 2
As Fedora 16 is officially out, I bit the bullet and attempted to do a "preupgrade" of Fedora, from version 15 to 16. I did not even know of the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353

    Fedora 16 upgrade


    As Fedora 16 is officially out, I bit the bullet and attempted to do a "preupgrade" of Fedora, from version 15 to 16. I did not even know of the existence of this capability until I ran across this article this morning.

    Well, I first backed up everything of course, then I proceeded with the instructions in the above link. I did not have to worry about the /boot space mentioned there b/c my /boot is not a separate partition.

    It was with more than a little trepidation that I su'd to root and began the process...but less than 1 hour later, I am happy to report that the upgrade proceeded seamlessly and I was able to log in to my new desktop after one reboot (and restoring my backed up files/dirs).

    Well, wait a minute - I have one clarification: the kernel people (I'm guessing) decided to change the kernel device name for my Broadcom NetXtreme BCM5751 GBE network adapter from em1 to p2p1. It took me a couple minutes to work out the problem, b/c systemd chews up and spits out /etc/init.d/network errors, but I got it sorted. Basically, I just had to do:
    Code:
    cat /etc/sysconfig/network-scripts/ifcfg-em1|sed -e 's|^DEVICE=.*$|DEVICE=p2p1|' > /etc/sysconfig/network-scripts/ifcfg-p2p1
    rm -f /etc/sysconfig/network-scripts/ifcfg-em1
    service network restart
    I can't really fault Fedora for that, but it would have been nice if they had something in the upgrade process that caught that.

    Anyway, the non-upgrade-ability of Fedora is finally history for me - w00t! Kudos to the hard-working geeks @ the Fedora Project!

    EDIT: one more thing - it did not automatically install grub2 to the MBR, so I was using the old grub menu when I rebooted (thus, did not boot into new F16 kernel). Easy fix (posted here):
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    grub2-install /dev/sda
    EDIT 2: another two things: yum update failed b/c it wanted java-x.x.x-openjdk but could not figure out how to install it. fixed that with:
    Code:
    yum install java-1.6.0-openjdk
    also, nautilus was broken (i.e., no desktop icons and trying to access Home Folder via Places did not work). The package nautilus-terminal apparently needs to be updated, but it is not in the F16 updates repo yet. Removing this package fixed that:
    Code:
    yum erase nautilus
    I hope there are not too many more edits in my future...

    EDIT 3: The cups printing service was off-line, dag nabit. Had to do:
    Code:
    yum update --enablerepo=updates-testing cups-1.5.0-19.fc16
    Then I could successfully start it with:
    Code:
    systemctl start cups.service
    But I wanted to make sure it came up after reboots so I did:
    Code:
    systemctl enable cups.service
    Then rebooted...and yes, printing works again.
    Last edited by atreyu; 11-09-2011 at 08:11 PM. Reason: cups

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    I was a bit more ballsy - I saw the release news article flow past on /. and immediately grabbed my netbook. I opened the lid and connected to my employers non-core wireless network and ran the preupgrade tool. I've used it before so it held no surprises. I ran no backups, took no precautions and I didn't even wait a couple of months for the new Fedora to stabilise, I just dived right in.

    And nothing happened - no drama, no failed hardware, no lost files. It just updated, then I rebooted. The only changes (apart from kernel 3.x which looks unusual, but isn't) is that the wireless now seems to connect slightly quicker and the snooze/wakeup is a bit faster.

    Also I ought to point out to people that my netbook has a 'disposable' environment. I keep nothing on it that I don't have a copy of elsewhere, or that I couldn't afford to lose (it is, after all, ultra portable so could go missing completely). I don't recommend anyone do what I did.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •