Find the answer to your Linux question:
Results 1 to 2 of 2
hi fellow linux users I recently did a manual install of a lexmark X1150 printer driver on ubuntu 12.04 on a 64 bit mini-pc desktop computer. The exact same driver ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! fenario's Avatar
    Join Date
    Mar 2009
    Location
    Rylstone NSW Australia
    Posts
    36

    Smile 32 bit packages on 64 bit machine made lexmark printer work.


    hi fellow linux users

    I recently did a manual install of a lexmark X1150 printer driver on ubuntu 12.04 on a 64 bit mini-pc desktop computer. The exact same driver was installed on a 32 bit laptop and it worked well. on the 64 bit machine it just didn't want to work at all. the error message had something with the number 64 and the word: false in it. It didn't dawn on me for quite some time that it meant 64 bit packages were not appropriate for this old printer. So I installed all the files possible to do with libcups in 32 bit architecture. To double click on the packages which I downloaded did not work. gdebi just said they were already installed. Using gdebi via the terminal then allowed me (apart from a few files that would be clashing) to install these files:
    libcups2:i386 (1.5.3-0ubuntu6),libcupsfilters1:i386 (1.0.18-0ubuntu0.1),libcupsdriver1:i386 (1.5.3-0ubuntu6)
    ,libcupsimage2:i386 (1.5.3-0ubuntu6), libcupsmime1:i386 (1.5.3-0ubuntu6), libcupsppdc1:i386 (1.5.3-0ubuntu6) and libcupscgi1:i386 (1.5.3-0ubuntu6) and voila; the printer worked and this after mucking around for a few days. Another happy tux moment. I felt that I need to share this story as it may save others from getting frustrated.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Thread moved here to the coffee lounge as it doesn't really seek help. Thanks for posting it though. I'm sure it'll come in handy for someone.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •