Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    13

    Just did a complete reinstall of Debian to try to overcome this problem.... even during the installation process, when trying to check apt sources, it failed in the same menner as I have indicated above.
    I have been doing a little research on my ISP (iprimus.com.au) and in their supplied "minimum system requirements" are all windows based, with not a mention of Linux to be found. Is there a chance that the ISP will simply not communicate with linux, but somehow Konqueror gets around this?

    Just a thought, probably off the mark, but I figure someone may have an idea on this.


    dreamboat

  2. #12
    Just Joined!
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    13
    Note - after new install, mozilla works also... but still not apt!




    dreamboat

  3. #13
    That's very strange. After I posted my sources.list , I checked it again with

    apt-get update

    and it worked fine on my system. About the ISP, my ISP told me that they
    don't support linux and the installtion disc that I got with the DSL modem only
    works with Windows. Without their installation disc, I haven't got any problem
    using it at all.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux User
    Join Date
    Apr 2005
    Location
    Ohio
    Posts
    326
    Quote Originally Posted by dreamboat
    Vidd,

    Err http://http.us.debian.org stable/main Packages
    Could not connect to http.us.debian.org:80 (1.0.0.0) , connection timed out

    [Connecting to ftp.au.debian.org (1.0.0.0) ]
    Looks to me like your system is having name resolution issues.. it seems to be resolving the IP address for everything as 1.0.0.0

    check your /etc/resolv.conf file to make sure the proper name servers are in there.
    itg-debian:/# cat /etc/resolv.conf
    nameserver 192.168.0.25
    nameserver 192.168.0.24
    the name server listings should be your ISP's name servers.. OR the ip address of your router if it forwards DNS requests for you.


    Play around with dig to see what your name servers are returning for your DNS queries. Every time you go to an address on the Internet aDNS lookup is made to resolve the name to an IP address.
    itg-debian:/# dig security.debian.org

    ;; QUESTION SECTION:
    ;security.debian.org. IN A

    ;; ANSWER SECTION:
    security.debian.org. 3600 IN A 128.101.80.133
    security.debian.org. 3600 IN A 82.94.249.158
    security.debian.org. 3600 IN A 194.109.137.218
    itg-debian:/# dig ftp.au.debian.org

    ; <<>> DiG 9.2.4 <<>> ftp.au.debian.org
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5330
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ftp.au.debian.org. IN A

    ;; ANSWER SECTION:
    ftp.au.debian.org. 3600 IN CNAME ftp.planetmirror.com.
    ftp.planetmirror.com. 3599 IN A 203.16.234.86
    ftp.planetmirror.com. 3599 IN A 203.16.234.85
    You can query a specific DNS server by putting the server address following the query .. i.e. :
    itg-debian:/# dig ftp.au.debian.org @192.168.0.24

    If you are not getting valid responses to your DNS queries then you will have problems going places..
    far...out

  6. #15
    Just Joined!
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    13

    Smile

    Thank you farslayer!

    Problem is now mostly solved.

    my nameserver was set at 192.168.0.1

    I checked my modem settings, and it uses two DNS addys, one of which I put into the /etc/resolv.conf file

    Only problem, is that this value keeps reverting back to the old 192.168.0.1 after I manage to get one install done.


    resolv.conf reads:

    search mshome.net
    nameserver 192.168.0.1


    Seems to me that the first line there is telling the system to get a new value from mshome.net? I will try to # that line out, and see how it goes.



    Thanks
    Dreamboat

  7. #16
    Just Joined!
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    13
    -->
    Well.... using a # did not permanently fix the problem, so I completely deleted that first line.
    Looked like it was sorted, but 5 minutes later, the resolv.conf file had changed back to its complete original form!

    Suggestions?

    Nearly there though.....

    dreamboat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •