Find the answer to your Linux question:

View Poll Results: Can you reach that URL I mentioned?

12. You may not vote on this poll
  • Yes (and running etch)

    0 0%
  • Yes (but not running etch)

    3 25.00%
  • No (and running etch)

    7 58.33%
  • No (but not running etch)

    2 16.67%
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    bizarre lack of HTTP response problem

    As of the last couple of weeks my computer running etch cannot get an HTTP response from a very few particular URLs. But I can access web pages using different computers on the same network (running sarge and ubuntu 6.06LTS) and even with this computer by using an ubuntu (6.06LTS) live CD. Hence, I think the problem must stem from a recent update to etch.

    Here is a page I can't get:

    If anyone running a fully updated (x86) etch system can get this page, then I would certainly appreciate a reply.

    I can't get it with Iceweasel, Opera, wget, etc. Here is the output from wget:

    [etch] $ wget
               => `bigcal.html'
    Connecting to||:80... connected.
    HTTP request sent, awaiting response...
    As you can see, it connects, sends a request, but cannot receive a response.
    Look: I can even ping the server:

    [etch] $ ping
    PING ( 56(84) bytes of data.
    64 bytes from ( icmp_seq=1 ttl=104 time=52.1 ms
    64 bytes from ( icmp_seq=2 ttl=104 time=55.6 ms
    64 bytes from ( icmp_seq=3 ttl=104 time=52.3 ms
    Here is the output from wget using a sarge computer on my network:

    [sarge] $ wget
               => `bigcal.html'
    Connecting to[]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 78,195 [text/html]
    100%[======================================================>] 78,195       214.40K/s
    00:53:40 (213.69 KB/s) - `bigcal.html' saved [78195/78195]
    The weird thing is that I can access pretty much every other site I have tried. (I am using the etch machine to write this right now!) Once again, if anyone can access this URL, please reply.

  2. #2
    Wow, that is quite odd. I tried from my laptop (etch, x86) using epiphany and I also can't connect. However, it will work when using the internet archive's copy of the site

    I will have to try it from sid when I get home tonight....
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Ok, it works on my sid box (x86).......
    Brilliant Mediocrity - Making Failure Look Good

  4. $spacer_open
  5. #4

    that's at least one confirmation

    Vergil83, thanks. This is evidence that it is an etch problem and not some issue related to my configuration. It would be good if we could get word from a few more etch users about whether they can get an HTTP response from that server.
    Last edited by samething22; 02-28-2007 at 01:08 AM. Reason: mis-spelled a user's name

  6. #5
    Running Etch , up to date and cannot connect--very odd

  7. #6

    time to file a bug report?

    It looks like there's enough evidence to suggest that there really is something funny going on with etch. It seems to me that if you can get to this site using any other OS, you should be able to get to it with etch as well.

    I would like to go ahead and file a bug report. However, I do not know what package I would file it against. (Recall that the problem is browser-independent.)

    Any ideas?

  8. #7
    I think it is a dns problem. I used netcraft to find the ip of the address (it is running windows 2003 server!). I can ping the ip just fine
    Brilliant Mediocrity - Making Failure Look Good

  9. #8
    Ok, you already did that! My mistake
    Brilliant Mediocrity - Making Failure Look Good

  10. #9
    You might try a bug report with at bind9. This controls both dnsutils and libdns22
    Brilliant Mediocrity - Making Failure Look Good

  11. #10
    yeah, my first thought was that it was some kind of DNS problem. But the weird thing is that I can ping the server (using its name or its IP) from my etch machine. But that machine can't receive an HTTP response. Do you have any idea what package this might have to do with?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts