Find the answer to your Linux question:
Results 1 to 5 of 5
debian etch will not let me login as root from login screen it says "root not allowed to login" from bash it says "permission denied" im new to debian etch ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    6

    at login screen - "Root not allowed to login"


    debian etch will not let me login as root
    from login screen it says "root not allowed to login"
    from bash it says "permission denied"

    im new to debian etch and this is a fresh install.
    is this standard operation in debian to kill the root user
    if so how on earth do i enable the root account again ?

    help
    K

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Many distros do not allow root to login to an X session via a login manager. You can change this by running gdmsetup if using GNOME and look for the security settings and choose to allow root logins. If you use KDM then you will have to run Kcontrol -> System Administration -> Login Manager.

    If you cannot login from the CLI, then I suspect that maybe you are entering the wrong password. Try logging into single user mode and then changing the root password.

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    7
    At least in Debian Etch, and as far back as Sarge (first Debian Version I used) I know that the Default Login Manager will allow you to configure it to log in with root, and it is TONS easier.

    When X first starts and it ask for login, at the bottom of the screen there are buttons, (Use to be three, but in Etch it is just one says Options) if you click it there is a menu, in the menu there is the option, 'Configure Login Manager'

    The system will ask to verify root password before allowing you to configure, if your root password is correct it will give you a box, tabs across the top and options. There is a Tab called Security, on that tab you will find a check box, 'Allow Local System Administrator Login' If you Check that, you may login as root using the Login Manager.

    Now I know this information is correct with Debian, I would imagine settings to be similar in other distros.

    TeddyB

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    GUI or CLI?

    If the latter, post your /etc/securetty.

  6. #5
    Just Joined!
    Join Date
    Sep 2007
    Posts
    7

    Lightbulb DUH! *Slaps Head*

    Quote Originally Posted by kextex View Post
    from login screen it says "root not allowed to login"
    from bash it says "permission denied"
    K
    Oh, so you can't login as root at all..... That seems, like..... bad...

    For some reason I missed the part about the bash alltogether..
    Feel so stupid.

    It isn't standard operations in debian for this to happen. being you said it is a fresh install I think your best bet may be to format the disk and install again, if possible.

    otherwise maybe anomie could help you troubleshoot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •