Find the answer to your Linux question:
Results 1 to 5 of 5
hi people, i have windows xp and debian installed on my system. i had xp running initially. later i installed debian on it. i installed debian using an installer my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    cant boot into windows


    hi people,
    i have windows xp and debian installed on my system.
    i had xp running initially. later i installed debian on it. i installed debian using an installer
    my problem is that i cant boot into xp . following is the o/p from fdisk

    Device Boot Start End Blocks Id System
    /dev/hda1 1 917 7363408+ b W95 FAT32
    Partition 1 does not end on cylinder boundary.
    /dev/hda2 * 917 8085 57576960 7 HPFS/NTFS
    /dev/hda3 8086 9667 12707415 83 Linux
    /dev/hda4 9668 9729 498015 f W95 Ext'd (LBA)
    /dev/hda5 9668 9729 497983+ 82 Linux swap

    after the installation i couldnt boot into xp as there was no option to do so. during booting. so i installed grub and did update-grub..
    i also added this entry to my grub file but it wont help..

    title Windows XP
    root (hd0,1)
    makeactive
    chainloder +1

    any help to solve the problem would be greatly appreciated
    thanks
    jay

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    any error messages listed?
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    i dont get any error. i tried to add hda2 to the grub file but i still cant get it right. so would just adding win to grub list would help solve the problem. or do i have to do something else
    thanks
    jay

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3
    i tried to edit grub my adding (hd0,4) for my winxp . then i got unknown partition type 0x82 .any clues what should i do
    jay

  5. #5
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    Re: cant boot into windows

    Quote Originally Posted by jay_uccs

    title Windows XP
    root (hd0,1)
    makeactive
    chainloder +1
    Not sure if you solved the problem by now, just noticed either a typo in the above or an error in your config:

    chainloader +1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •