Find the answer to your Linux question:
Results 1 to 5 of 5
With the latest packages of Debian, it seems to have over come my WUSB11v4 wifi card. It's a little older, yes, but Linux is known for it's renown support in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! SZF2001's Avatar
    Join Date
    May 2006
    Posts
    67

    (wireless) WUSB11v4 doesn't work with new installs.


    With the latest packages of Debian, it seems to have over come my WUSB11v4 wifi card. It's a little older, yes, but Linux is known for it's renown support in new and old modules alike.

    Does anyone have any luck with this particular driver? People tell me it just works "out of the box" once they plug it in through the USB drive, but for me it's a different story.

    It is recodnized, but not as a wifi card. So I install ndiswrapper. It becomes recodnized but then it can't recieve any signal, although it can send it to see all the routers out there.

    How does MadWifi work? I have heard of this before, but I'm not even sure about what it is or does. Is it a program? Does it run with the terminal or does it have a GUI? Does it come with drivers? I just don't know.

    If there are any usuers succesful with the WUSB11v4 card, please fill me in on your secret.

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    14
    madiwifi works for me, but I think its only for atheros chipsets. Make sure your interfaces file is configured for it. type this command in terminal and post the output.

    cat /etc/network/interfaces

    I just finished configurations with the madwifi driver for my wireless card. Also you can try downloading kwlan. That has a gui for configuration and allows you to choose which driver you want to use with the wireless card.

    E

  3. #3
    Just Joined! SZF2001's Avatar
    Join Date
    May 2006
    Posts
    67
    OK, I did as you said. Something you should know though - I am using Windows since it's working with the wireless until I get this mess figured out, so for now I just slapped in the old Ubuntu Breezy live CD (I know, not the latest), so if I need to check with the latest OS I guess I could download one real quick.

    Anyway, the results:

    Code:
    /etc/network/interfaces
    
    ubuntu@ubuntu:~$ cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # This is a list of hotpluggable network interfaces.
    # They will be activated automatically by the hotplug subsystem.
    mapping hotplug
            script grep
            map eth0

  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    14
    theres no wireless interface listed in your /etc/network/interfaces file. Heres my interface file so you can see what I mean.

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug ath0
    iface ath0 inet dhcp

    auto ath0


    iface eth0 inet dhcp

    My wireless card is ath0. When you type iwconfig your card should be listed. If not then its not installed properly. When you use the iwconfig command, make sure you remember what the linksys card is called so you can add that to your interfaces file like this

    The primary network interface
    allow hotplug (linksys card)
    iface (linksys card) inet dhcp

    auto (linksys card)

    If that doesn't work then you may have installed it incorrectly. Check your iwconfig output along with your ifconfig output and see if that works for you.

  5. #5
    Just Joined! SZF2001's Avatar
    Join Date
    May 2006
    Posts
    67
    Hey, I figured this out! Holy crap! I see nothing but problems when it comes to this particular device when searching on Google, but now I've figured it out.

    Here's what I did:

    1 - Do the ndiswrapper procedure installing WUSB11v4.inf - you can either use the latest build or you can use whatever version you have packed with Debian... This wifi card is a bit older so it should be recodnized.
    2 - Get Wifi-radar (just search that in Synaptic Package Manager or type 'su apt-get install wifi-radar').
    3 - Go to System -> Preferences -> Sessions. Turn off "Network Manager".
    4 - Reboot, or manually turn off Network Manager (even though when I tried that it didn't work, so I suggest the Reboot so you have a session that's never started the Network Manager).
    5 - Once your computer starts up again, make sure the little Network Manager icon isn't in your system tray - that's the sign showing you've successfully turned off the Network Manager.
    6 - Use Wifi-radar to configure everything. If it doesn't work at first, make sure you've edited the Profile CORRECTLY - I thought, at first, that Wifi-radar wasn't working until I noticed a typo in my keycode and I didn't set it to Managed.

    Success!

    You just have to use Wifi-radar every time you turn your computer on after a shutdown, but that shouldn't be too much of a hassle since the profile is saved...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •