Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have these NFSv4 exports on my Debian Etch server: Code: /drbd/nfs_exports 192.168.4.0/24(ro,sync,no_subtree_check,fsid=0) /drbd/nfs_exports/usr 192.168.4.0/24(rw,sync,no_subtree_check) /drbd/nfs_exports/usr is on the same filesystem as /drbd/nfs_exports. On a client I mount /usr ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1

    NFSv4 exports


    Hello,

    I have these NFSv4 exports on my Debian Etch server:

    Code:
    /drbd/nfs_exports        192.168.4.0/24(ro,sync,no_subtree_check,fsid=0)
    /drbd/nfs_exports/usr    192.168.4.0/24(rw,sync,no_subtree_check)

    /drbd/nfs_exports/usr is on the same filesystem as /drbd/nfs_exports. On a client I mount /usr using this command:

    Code:
    mount -t nfs4 local.nfs:/usr /mnt
    (where local.nfs is the NFS server, 192.168.4.201)

    The problem is that /usr is now mounted read only. Apparently the NFS server is using only the first line of my exports, where it should be using the second line. Everything works fine when I change my exports to

    Code:
    /drbd/nfs_exports        192.168.4.0/24(rw,sync,no_subtree_check,fsid=0)
    /drbd/nfs_exports/usr    192.168.4.0/24(rw,sync,no_subtree_check)
    (the first line now reads rw instead of ro)

    But I don't want my NFS root /drbd/nfs_exports to be exported to all clients with write permission. All examples say that my configuration should work fine, but it doesn't. Is this a bug or am I overlooking something?

  2. #2
    Just Joined!
    Join Date
    Apr 2009
    Posts
    1

    NFSv4

    Try using the "nohide" option on the export that isn't showing up. I had a similar issue and this seemed to fix it.

    Kind Regards,
    Bill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •