Find the answer to your Linux question:
Results 1 to 4 of 4
I am trying to install nvidia-glx since I would like to move my on work Cg shaders from Windows to Linux(Debian Etch). As a videocard I have an old Nvidia ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Delft, Holland
    Posts
    95

    Apt-get and older versions of applications


    I am trying to install nvidia-glx since I would like to move my on work Cg shaders from Windows to Linux(Debian Etch). As a videocard I have an old Nvidia ti-4200 but that should still support low shader profiles.

    When I try to installed the package, I get this:
    Code:
    Inanna:~# apt-get install nvidia-glx
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      nvidia-glx: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch4 is to be installed
                  Depends: nvidia-kernel-169.07 but it is not installable
                  Depends: xserver-xorg-core (>= 2:1.4) but 2:1.1.1-21etch1 is to be installed
    E: Broken packages
    The depends lines are confusing, I have 2.3.6.ds1-13etch4 but that "is to be installed"? I'll just assume that I need libc6 v2.7-1 but I don't think that it is smart to update libc6 since that would break most of my system.

    So, here are my questions:
    (a) Why can I not install nvidia-kernel-169.07?
    (b) How do I get a version of nvidia-glx that matches the system I have? I can live with an older version.

    Thank you for reading.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I think you'll need this legacy driver for that card and the latest drivers will not work with it. You can go here and fill out the search boxes to make sure which driver goes with your card.
    oz

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Delft, Holland
    Posts
    95
    Oh yeah, I overlooked the fact that 169xx is the series of drivers for their latest cards. I do have the correct driver installed (96xx). I found an nvidia-glx-legacy-96xx package, but this depends on the nvidia-kernel-legacy-96xx-96.43.01 package and that cannot be installed:
    Code:
    Inanna:~# apt-get install -t sid nvidia-kernel-legacy-96xx-96.43.01
    Reading package lists... Done
    Building dependency tree... Done
    Package nvidia-kernel-legacy-96xx-96.43.01 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package nvidia-kernel-legacy-96xx-96.43.01 has no installation candidate
    I know that this should exist somewhere in sid and I have the following line added to sources.list file:
    Code:
    deb http://ftp.us.debian.org/debian/ sid contrib non-free
    Again, thank you for reading.

  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    17
    Quote Originally Posted by Morgoth View Post
    Oh yeah, I overlooked the fact that 169xx is the series of drivers for their latest cards. I do have the correct driver installed (96xx). I found an nvidia-glx-legacy-96xx package, but this depends on the nvidia-kernel-legacy-96xx-96.43.01 package and that cannot be installed:
    Code:
    Inanna:~# apt-get install -t sid nvidia-kernel-legacy-96xx-96.43.01
    Reading package lists... Done
    Building dependency tree... Done
    Package nvidia-kernel-legacy-96xx-96.43.01 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package nvidia-kernel-legacy-96xx-96.43.01 has no installation candidate
    I know that this should exist somewhere in sid and I have the following line added to sources.list file:
    Code:
    deb http://ftp.us.debian.org/debian/ sid contrib non-free
    Again, thank you for reading.
    Its recommend to do it like this:
    Preparation
    Code:
    # apt-get install gcc gcc-4.2 nvidia-kernel-common module-assistant linux-headers-(uname -r)
    # m-a -i prepare
    # cd /tmp
    # wget http://us.download.nvidia.com/XFree86/Linux-x86/96.43.01/NVIDIA-Linux-x86-96.43.01-pkg1.run
    Killing gnome
    Code:
    # /etc/init.d/gdm stop
    Login as root
    Code:
    # cd /tmp
    # chmod +x NVIDIA-Linux-x86-96.43.01-pkg1.run
    # ./NVIDIA-Linux-x86-96.43.01-pkg1.run
    Follow instructions if it says GCC version is wrong simply adjust it with:
    Code:
    export CC=gcc-X.X
    (replace x with GCC version, Displayed in the error)

    After setup is done and was an success!
    Code:
    # nano /etc/X11/xorg.conf
    Should look like this after editing:
    Section "Device"
    Identifier "nVidia Corporation NV18 [GeForce4 MX 4000]"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection
    Starting Gnome
    Code:
    /etc/init.d/gnome start
    Thats how I install my drivers.
    If your still having problems you could always try this document it contains an other way to install. It has allot of explenation. Its allot simpler aswell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •