Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi I'm kind of new to all the linux stuff but the first thing i notice when firing up gnome is that the monitor doesn't display everything too clearly and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    8

    Monitor resolution?


    Hi I'm kind of new to all the linux stuff but the first thing i notice when firing up gnome is that the monitor doesn't display everything too clearly and way to bright. I tried playing with the xorg.conf but still no success. Does it have something to do with a wrong driver because I have no idea how to fix that. Need help!!

    I'm using:

    Samsung SyncMaster 206BW
    Ati Radeon HD 3850

    my xorg.conf

    Section "Device"
    Identifier "ATI Technologies Inc ATI Default Card"
    Driver "vesa"
    BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "SyncMaster"
    VendorName "Samsung"
    ModelName "206BW"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    DisplaySize 1680 1050
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc ATI Default Card"
    Monitor "SyncMaster"
    DefaultDepth 24
    SubSection "Display"
    Modes "1680x1050"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which version of Debian do you have? You have to install ATI Driver. Execute this
    Code:
    cat /etc/debian-release
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    8
    Casper,

    I just installed ati's catalyst driver 8.01-x86 but when I restarted Xorg the screen just got worse and text was ubersmall at login and some other apps. Also, the windowmanager lags big time now. I tried the aticonfig --initial -f command but still got these problems. Anyway the output of the file you requested doesn't exist but I do have debian_version file. The output is:

    lenny/sid


    thanks for you reply

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Section "Monitor"
    Identifier "SyncMaster"
    VendorName "Samsung"
    ModelName "206BW"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    DisplaySize 1680 1050
    EndSection
    Are HorizSync and VertRefresh rates supported by your Monitor? Check Monitor's Manual. Check Resolutions too. You have to edit xorg.conf file manually.

    Anyway the output of the file you requested doesn't exist but I do have debian_version file. The output is:

    lenny/sid
    My mistake. Correct filename is debian_version only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    8
    Yes, I've checked the manual that these are correct settings. The perfect setting for this monitor would be 1680x1050@60Hz. Although I manage to get that setting, the quality still isn't what it should be. Could this be driver related ?

    Regards

    on a sidenote: when I try to switch back to my original xorg.conf file, I get the login screen but when I try to log in, the screen flickers and xorg seems to reset so I get the login screen again. what's happening ? I want to get rid of the ati driver =(

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+F2 and type this
    Code:
    gksu gedit /etc/X11/xorg.conf
    It will open xorg.conf file in Gedit with root privileges.
    Replace Driver "ATI" with "vesa", save file and press Alt+Ctrl+Backspace OR reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Jan 2008
    Posts
    8
    I changed it into vesa like you said but when restarting xorg results in not being able to log in. So when I get the login screen but when it tries to log in it gets back to the login screen.

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+Ctrl+F1. It will drop you at command line login prompt. Check if it allows you to log in. If you logs in successfully, execute this
    Code:
    su -
    /etc/init.d/gdm stop
    startx
    Post error message here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Jan 2008
    Posts
    8
    I got this message:


    Fatal server error:
    Caught signal 11. Server aborting
    xinit: connection to x server lost


    Do you think it's a better idea to install the free open source drivers?
    I got the xf86-video-ati-6.7.197.tar.bz2 file

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try it. Extract tar file and read instructions carefully in ReadMe file first.


    Have you tired executing this
    Code:
    su -
    dpkg-reconfigure xserver-xorg
    Select default options and select 'vesa' driver in Drivers List.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •