Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I'd like to use LaTeX equations and formulas in OpenOffice documents (writer and impress), and I found this really neat project called OOoLaTeX by gpiroux ( OOoLatex, get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164

    running OOoLaTeX on etch (LaTeX math in OpenOffice)


    Hi all,

    I'd like to use LaTeX equations and formulas in OpenOffice documents (writer
    and impress), and I found this really neat project called OOoLaTeX by gpiroux
    (OOoLatex, get the power of LaTeX into OpenOffice !)
    It's a set of macros that lets you type LaTeX math code, generates a picture
    of the formula and inserts it into your document.

    Now I would like to make this work in Debian etch. My main question is: has
    anybody here succeeded in installing OOoLaTeX in Debian?

    I tried all versions available on sourceforge, but I end up getting the
    following error message:
    The extension cannot be installed as the following system dependencies are not fulfilled: Unknown.
    which, according to gpiroux indicates a conflict of OOo versions.
    But I'm reluctant to install a non-Debian version of OOo.

    There's apparently work on a Debian package ooolatex, but it's "365 days in preparation"
    -- I'm not sure what this means but it doesn't look very active.
    Maybe someone can tell me what this means?

    The Ubuntu people apparently made it work,
    maybe somebody has experience using the Ubuntu deb in Debian?

    thx, kai

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164

    SOLVED: running OOoLaTeX on etch (LaTeX math in OpenOffice)

    hi all,

    i managed to get this sorted out myself.
    remembering the Debian backports project i added
    Code:
    deb http://www.backports.org/debian etch-backports main contrib non-free
    to my /etc/apt/sources.list, ran apt-get update and then upgraded the
    openoffice.org package (using -t etch-backports with apt-get install).

    This gives me OpenOffice.org 2.3.1 whereas etch is running 2.0. With this,
    I could install the ooolatex extension file (.oxt) from sourceforge no problem.
    I also downloaded latex2emf and ran it - it copies some libraries to /usr/lib/
    so it shouldn't cause trouble with my system, and OOoLatexFonts.zip.

    The latter contains truetype fonts for «expanding» LaTeX to truetype characters
    rather than running LaTeX and including figures with the output.
    Those fonts I put in a new directory /usr/share/fonts/truetype/ooolatex
    and then ran
    Code:
    dpkg-reconfigure fontconfig
    to update the font cache etc.

    Upon a first look, all seem to work perfectly. Great work, gpiroux!

    cheers, kai

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •