Hi Guys,

I have just installed a local DNS Server. Everything works fine but now I cannot receive pop mail anymore from my ISP. I guessed that was due to my DNS server but I cannot fixe the problem. I have enclosed below my DNS configuration files. The only I have done is a forwarder as I have attached to my network a router. I did try a forwarder with my ISP's DNS but that didnt work at all.
Any help I could get here is very much appreciated because I am really stuck. Finally, I have another email account that works fine on the same network. That account is not from my ISP but it is a Mac.com account. It is a pop mail account but to get my emails, i use mail.mac.com and not pop.mac.com. Is it why that one is working and not the one from my isps which uses pop.orange.fr ?? Plus, my google account which uses pop.google.com doesn't work anymore as well.

Again, thank you all for your help

Here is my db.macitos.fr file

$TTL 604801
@ IN SOA margoullat.macitos.fr. leonidas.margoullat.fr (
20041122 ;
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Minimum

NS margoullat.macitos.fr ; Name of server
margoullat A 192.168.1.7 ; IP address of the name server
margoullat HINFO "AMD64 " "Debian etch" ;

iguane A 192.168.1.8
margoullat A 192.168.1.6
margoullat A 192.168.1.7
zongo A 192.168.1.5
heaven A 192.168.1.10


perso CNAME zongo
ig CNAME iguane
mar CNAME margoullat
mac CNAME heaven
pop CNAME iguane
smtp CNAME iguane


Here is my named.conf.local


zone "macitos.fr" {
type master;
file "/etc/bind/db.macitos.fr";
forwarders{};
};

zone "1.168.192.in-addr.arpa" {
type master;
file "/etc/bind/db.macitos.fr.inv";
forwarders{};

This is my named.conf.options file


forwarders {
192.168.1.1;
};

auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };