Find the answer to your Linux question:
Results 1 to 8 of 8
I got USB storage device Tragant DeLock usb2.0, pluged in usb1.0, but it doesn't matter. Kernel compiled with usb support. When i plug this device in, it starts blinking and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    CZech
    Posts
    9

    USB storage device


    I got USB storage device Tragant DeLock usb2.0, pluged in usb1.0, but it doesn't matter. Kernel compiled with usb support. When i plug this device in, it starts blinking and is connected at /dev/sg0. But! Everytime i tried to mount the dev point, it says something like Unable to mount filesystem or something. Do i need some packege? Or what should i do to access this storage device? I would really appreciate some advice! thanx

  2. #2
    Just Joined! sir_saucealot's Avatar
    Join Date
    Aug 2004
    Posts
    41

    USB Device

    Hi nemozny,

    Try mounting /dev/sda to somewhere - I had a very similar problem to the one you are describing, and this was the solution for me.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Location
    CZech
    Posts
    9
    when i added /dev/sg0 to fstab with "auto" type and then try mount /dev/sg0 it says that
    "/dev/sg0 is not block device"
    /dev/sda i cannot mount either, "its not valid block device"

  4. #4
    Just Joined! sir_saucealot's Avatar
    Join Date
    Aug 2004
    Posts
    41
    Ok,

    The only thing I have left to suggest is:

    mkfs /dev/sg0

    This will wipe everything off you USB device though.

    Sorry I can't be more help,

    Sauce

  5. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Try this

    If you have a look through the file /proc/bus/usb/devices, you should see a section with an S: line and the name of your reader and an I: line with Driver=usb-storage. If you see that, the kernel is recognizing the USB device.

    Install the sg3-utils package if you haven't already (on Debian, apt-get install sg3-utils). To check your SCSI devices, run the command sg_scan -i . You should see something like this:

    /dev/sg0: scsi0 channel=0 id=0 lun=0 [em] type=0
    eUSB Compact Flash 5.09 [wide=0 sync=0 cmdq=0 sftre=0 pq=0x0]

    This indicates that the "raw" SCSI device associated with your reader is /dev/sg0. You can also confirm that the driver is working by looking at the file /proc/scsi/scsi .

    Now, run the command sg_map to determine the real SCSI device associated with your reader. You'll see output like this:

    /dev/sg0 /dev/sda

    That's it. Your card reader is /dev/sda. The first (and almost certainly only) partition is /dev/sda1

    Grz. Okki
    Thanks to Greg Baker, see the full story @ http://www.cs.sfu.ca/~ggbaker/personal/cf-linux

  6. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    And then this worked for me

    I then tried mounting /dev/sda instead of /dev/sda1, this worked!
    ( so the previous post is for all the people googling to here ;D )

  7. #7
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    Yeah, Jasons mod has definetly been a benifit, we have a great PHR on google and commonly ore like 2-3 on the list.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  8. #8
    Just Joined!
    Join Date
    Aug 2004
    Location
    CZech
    Posts
    9
    thanx okki!! you're answer is correct. but i've made it worx already. i've moved my debian to other computer than the previous one, and it suddenly became working!!! i've done a few things but i don't think it was any solution - installed kudzu for automatic hardware detection and finally mounted not as /dev/sg0 but /dev/sda. but for the first time, kernel didn't react for plugging in the flash disk, but in the second computer kernel identified flash disk and i found /dev/sda in /var/log/messages. strange. Thank you okki!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •