Find the answer to your Linux question:
Results 1 to 7 of 7
I've been trying to install cinelerra on my lenny system but I keep running into dependency problems. I try aptitude, synaptic, and installing the .deb manually and always come up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    28

    Cinelerra dependency problem in Lenny


    I've been trying to install cinelerra on my lenny system but I keep running into dependency problems.

    I try aptitude, synaptic, and installing the .deb manually and always come up with the same error. Installing the libs hasn't been successful. The readout is

    Code:
    The following packages are BROKEN:
      cinelerra libmp3lame0 libquicktime0 
    The following NEW packages will be installed:
      libdc1394-13{a} libfftw3-3{a} libguicast{a} liblame0{a} libmjpegtools0{a} 
      libmpeg3hv{a} libquicktimehv{a} libsndfile1{a} 
    0 packages upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
    Need to get 23.6MB/25.2MB of archives. After unpacking 59.9MB will be used.
    The following packages have unmet dependencies:
      libmp3lame0: Conflicts: liblame0 but 3.97-0.0 is to be installed.
      cinelerra: Depends: libopenexr2ldbl (>= 1.2.2) which is a virtual package.
      libquicktime0: Depends: libavcodec0d (>= 0.cvs20060823) which is a virtual package.
    My sources.list
    Code:
    deb http://ftp.us.debian.org/debian/ lenny main
    deb-src http://ftp.us.debian.org/debian/ lenny main
    
    deb http://security.debian.org/ lenny/updates main
    deb-src http://security.debian.org/ lenny/updates main
    
    #cinelerra
    deb http://www.kiberpipa.org/~minmax/cinelerra/builds/sid/ ./
    deb-src http://www.kiberpipa.org/~minmax/cinelerra/builds/sid/ ./
    deb http://www.debian-multimedia.org/ testing main
    Anybody else have this problem or know a solution? Thanks.

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Location
    India
    Posts
    14
    Try adding the debian multimedia repositories from here and try again:

    Debian Multimedia Packages::Home

    Then install using synaptic or apt-get.

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    28
    Hi harishankar. I had that repo enabled. It seems that the problem lies liblame0. They have renamed it for some reason to libmp3lame0 but either haven't made it available yet or something. Someone suggested enabling the sid repo for the file but that didn't get me any further. I tried forcing the install and it would install, only the program would basically freeze once its opened. Now, when I install it, the dependency issue doesn't come up, but it freezes the same, so I don't think it's been solved yet.

    Any other ideas?

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    India
    Posts
    14
    In the debian multimedia repos, are you pointing to stable, testing or unstable? I have found that if you mix the main repos with a different branch it will give dependency problems.

    I've used "testing" for both the main distribution as well as for debian-multimedia and libmp3lame is correctly identified as the dependency for cinelerra, not liblame.

  5. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1
    yeah I was facing the same problem with dependencies... I found following the advice above solved my dependency problems and cinelerra installed for me however when it opens i get the same "freeze" problem as jmerkin.

    are there any ideas on why this is freezing up?

  6. #6
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3

    my solution

    for me this worked:
    before trying to install cinelerra set up repositories:
    (i have pentium4 but you may need some other, check on Cinelerra :: a video editor and compositor for Linux)
    Code:
    deb http://www.kiberpipa.org/~minmax/cinelerra/builds/pentium4/ ./
    deb http://www.debian-multimedia.org/ sid main
    then run synaptic, go to settings->preferences->distribution
    ! set Prefer version from unstable !
    and click OK

    reload repositories
    cinelerra should install now
    hope this will work for you as it did for me

  7. #7
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    heh, I just have installed debian squeeze, which is now testing and this still works only I changed line with debian mulitmedia reps to testing (from sid)
    and in synaptic settings->preferences->distribution
    ! set Prefered version from testing !

    what is funny is that I again had problem installing cinerella and accidentally found my own post above. It sure pays-off to share

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •