Find the answer to your Linux question:
Results 1 to 3 of 3
Hello. I am getting the error "Failed to start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Failed to start the X server


    Hello. I am getting the error "Failed to start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?" when I try to boot my 2000 iBook (Firewire) running debian 4.0r5 installed from debian-40r5-powerpc-businesscard.iso. When I try to diagnose the problem it displays a ton of information and I have no idea what it means. I tried running "dpkg-reconfigure xserver-xorg" and going through the questions with the default answers, but I ended up getting the same error.

    When I get the first xserver error, It asks if i want to view the X server output to diagnose the problem. Clicking Yes displays the information below.
    Code:
    X window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: UNKNOWN
    Current Operating System: Linux home 2.6.18-6-powerpc #1 Thu Oct 16 21:52:47 UTC 2008 ppc
    Build Date: 01 June 2008
    Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 2 10:43:59 1904
    (==) Using config file: "/etc/X11/xorg.conf"
    (WW) ****INVALID IO ALLOCATION**** b: 0xf0000400 e: 0xf00004ff
    correcting^G
    (EE) end of block range 0xefffffff < begin 0xf0000000
    (EE) Unable to find a valid framebuffer device
    (EE) R128(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
    (you may have look at the server log to see warnings)
    (EE) Screen(s) found, but none have a usable configuration.
    Fatal screen error:
    no screens found
    Using "lspci | grep VGA" returns "0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)"

    I read postings that advised using "r128" for the driver in /etc/X11/xorg.conf but it wouldn't work.

    I tried using "fbdev" for the driver because of information posted at Fedora - LinuxQuestions.org and I was able to get a momentary GUI display that would crash immediately. Postings that advised using 16 for the color depth resulted in the left half of the screen being stretched across the entire screen, and then crashing. When I tried using 8, the whole screen was displayed.

    Going back through "dpkg-reconfigure xserver-xorg" and selecting "fbdev" for the driver and setting the color depth to 8 I am able to run startx, sort of, until it crashes. The color scheme is diminished to a few shades of gray and blue and I get the three errors listed below. Now I am not able to do anything because I am automatically booting in to the broken GUI interface. I am able to use the GUI login, but then the errors appear when I log in. After selecting OK for the three error messages I'm left at a blank blue colored screen. Pressing Ctrl Alt Delete takes me back to the GUI login.
    Code:
    There was an error starting the GNOME Settings Daemon.
    Some things, such as themes, sounds, and background settings may not work correctly.
    The Settings Daemon restarted too many times.
    The last error was:
    System Exception: IDL:omg.org/CORBA/COMM_FAILURE:1.0
    GNOME will still try to restart the Settings Daemon the next time you log in."
    Code:
    There was a problem registering the panel with the bonobo-activation server.
    The error code is: 3
    The panel will now exit.
    Code:
    Nautilus can't be used now, due to an unexpected error.
    
    Show more details
    Nautilus can't be used now, due to an unexpected error from Bonobo when attempting to register the file manager view server.
    Can anyone advise how to resolve the problem? If not the display problem, then atleast how to get the laptop to boot to the command line instead of the GUI login because all I can do now is crash over and over.

    UPDATE: I logged in to the failsafe terminal and was able to edit /etc/X11/xorg.conf . I changed the driver from "fbdev" back to "ati", so now the iBook is back to displaying the "Failed to start the X server" error when it tries to boot. Atleast I am now able to use the command line to edit instead of the distorted GUI.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Try changing the driver from "ati" to "vesa". This should at least give you a low resolution screen.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Tried all the drivers

    vesa was not in the list of drivers provided by "dpkg-reconfigure xserver-xorg" but I tried it anyway by editting /etc/X11/xorg.conf, and it didn't work. I tried using each of the drivers listed by "dpkg-reconfigure xserver-xorg". The only one that displays graphical output is "fbdev", and as I have said fbdev's output looks terrible and causes errors.

    The drivers listed by "dpkg-reconfigure xserver-xorg" are:
    ati
    chips
    fbdev
    glint
    imstt
    mga
    nv
    s3
    s3virge
    savage
    sis
    sisusb
    tdfx
    trident
    vga

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •