Find the answer to your Linux question:
Results 1 to 3 of 3
Hi i tried to do apt-get dist-upgrade on my nokia n810 but that returns errors too...what does error code (1) even mean? this is what i get apt-get dist-upgrade Reading ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    23

    subprocess /usr/bin/dpkg returned an error code (1)


    Hi

    i tried to do apt-get dist-upgrade on my nokia n810
    but that returns errors too...what does error code (1) even mean?

    this is what i get
    apt-get dist-upgrade
    Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following NEW packages will be installed:
    bash e2fslibs e2fsprogs libacl1 libattr1
    libblkid1 libcomerr2 libss2 libuuid1
    ncurses-base ncurses-bin slang1a-utf8
    0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/2019kB of archives.
    After unpacking 5083kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    WARNING: The following packages cannot be authenticated!
    bash e2fslibs libblkid1 libcomerr2 libss2
    libuuid1 e2fsprogs ncurses-bin ncurses-base
    libattr1 libacl1 slang1a-utf8
    Install these packages without verification [y/N]? y (Reading database ... 17302 files and directories currently installed.) Unpacking bash (from .../bash_2.05b-26osso2_armel.deb) ...
    dpkg: error processing /var/cache/apt/archives/bash_2.05b-26osso2_armel.deb
    (--unpack):
    trying to overwrite `/bin/sh', which is also in package busybox Errors were encountered while processing:
    /var/cache/apt/archives/bash_2.05b-26osso2_armel.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    can any1 (please*10^10) help me get rid of this error??

    thanks
    unnati

  2. #2
    Just Joined!
    Join Date
    Nov 2008
    Posts
    1
    Here's what CBlue sugguested:
    After you get that error, try apt-get -f install to force an install of the files that didn't get loaded because of the error. Then try apt-get upgrade again, apt-get -f install back and forth until only the package that has the error is left.
    That particular course of action did not work for me, although it did work for some other people, so try it first.

    Here's what I did and this worked:
    1. Open terminal, type
    cd /var/lib/dpkg/info
    2. Remove the info files for the bad packages (WARNING, this is dangerous in some cases): Type
    sudo rm -f <badPackageNameThatWasn'tInstalledInYourCase>*
    3.
    sudo apt-get update -f
    and
    sudo apt-get upgrade,
    or, finally,
    sudo apt-get install <packageThatCouldn'tBeInstalledPreviously>
    .

  3. #3
    Content Team _madman_'s Avatar
    Join Date
    Jun 2006
    Posts
    53
    Sounds like you may have "busybox" installed. Busybox is a bunch of common programs reduced to one binary file. Then links are set to that one file using the common command names and busybox responds accordingly, depending on which link invokes it. It is mainly used for bootdisks, liveCD's, and the like - where having fully functional (large) commands is not necessary.

    If you are using your system on a memory limited device (which it sounds like), then you may need to stick with "busybox" because Bash would be too large. "/bin/sh" is a file that will invoke either Bash or Busybox.

    Why are you trying to upgrade anyway? If you notice, the only files that apt is bringing in for your "upgrade" appear completely unnecessary for your type of system.

    I said it before and I'll say it again: UPGRADES ARE BAD!
    Do not attempt to upgrade any system ever, unless you know the system thoroughly, and are prepared to handle many errors like this one. Always backup (/home,/etc,/boot,etc) and do a fresh install. And even then, you really don't have to upgrade your OS unless your missing major functionality - which should be years appart.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •