Find the answer to your Linux question:
Results 1 to 3 of 3
I have recently bought an Asus 901 and installed all the updates, programs etc. I now find that when I try to uninstall a program I get the message 'dpkg ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    1

    Uninstalling programmes (debian)


    I have recently bought an Asus 901 and installed all the updates, programs etc. I now find that when I try to uninstall a program I get the message 'dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.'
    So I did some research on the web (having never used linux before and not being all that tech-savvy). I changed my status to a power-user and tried many different ways to uninstall 'Digital tv' and 'Ez Powerpen Jr' etc. I have mainly been trying out different codes using the Console Window: urpme '<digital tv>' or 'rpm -e digital tv' etc. as I can not locate the files directly using the File Manager. The error message I usually get is: 'bash: syntax error near unexpected token `newline'.'
    I really want to know what else I can do as I have seemed to have exhausted the google search engine. lol
    Any help would be greatly appreciated.
    Many thanks,
    Christa.

  2. #2
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525
    have you tried dpkg --configure -a already, as the error message suggested?

    Also RPM won't work on Debian unless you install it. Debian uses apt-get and aptitude for downloading and installing packages.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    su -
    apt-get clean all
    dpkg --configure -a
    Post exact error message here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •