Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Installing glibc 2.4


    Hi, I'm looking for help regarding installing glibc 2.4 - some info about my system is below. I'm new to linux, and I'm trying to get gcc 4.1.1 to work(my distro didn't come with a compiler, AFAICT).

    I downloaded a binary for gcc, but it says I need glibc 2.4. I got 2.4, but now I don't know how to install it so that the system knows it's available. I unzipped it into a subdirectory in /lib, but that didn't do anything. It came with a makefile, but running it tells me that I need to configure it first. Running configure, I get "You must configure in a separate build directory." What does this mean? What's special about a build directory and how do I create one?

    I'll probably have followup questions, so thanks in advance.



    (ASUS Eee PC running the full desktop in Xandros, which I believe is related to Debian)

  2. #2
    apt-get command should work under Xandros... (Thats what Google says at least) I don't have direct knowledge of it but try under root or sudo or su

    apt-get install glibc-2.4

  3. #3
    I'm sorry; I should have stated before that I don't have internet access on that computer right now - that's the cause of all this trouble(long story).

    So, I need to do whatever apt-get install does - but by hand. How can I learn what that is?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    From a different machine, you can download the files you need using apt-get, transfer them to your computer, and then use apt-get to install them.
    Code:
    apt-get -d install gcc-4.1
    This will download the necessary files. Then use the following on your computer to install from these files.
    Code:
    apt-get --no-download --ignore-missing install gcc-4.1
    You'll have to figure out where "apt-get -d" puts the downloaded files, and then where --no-download expects the files to be.

    Good luck!

    PS: Welcome to the forums!
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  6. #5
    Thanks for the welcome and the quick reply.

    Every other computer I have access to is windows - is there a site/program/other that will let me do an apt-get without setting up another OS on my other machine?

  7. #6
    Using any other computer go to Google and type "glibc linux tar"

    Then untar (extract)

    Then run
    "make"
    "make install"

    and that should do it. Good luck.

  8. #7
    When I run make, I get:

    Makeconfig:84: sysdeps/../config.make: No such file or directory
    The GNU C library has not been configured.
    Run 'configure' to configure it before building.
    Try 'configure --help' for more details.
    make: Failed to remake makefile 'sysdeps/../config.make'.

    So, just in case, I ran make install anyway:

    Makeconfig:84: sysdeps/../config.make: No such file or directory
    The GNU C library has not been configured.
    Run 'configure' to configure it before building.
    Try 'configure --help' for more details.
    make: Failed to remake makefile 'sysdeps/../config.make'.
    install -m 644 include/limits.h /usr/local/include/limits.h
    (a bunch more similar installs, mkinstalldirs(?), and mkdirs), then
    (sed '/^@/d' include/stubs-prologue.h; LC_ALL=C sort ) > stubs.h

    after that, it didn't do anything else, but the process was still going. After about 30 seconds, I ctrl-ced.

    After all this, running mb-gcc gives the same message:

    /sbin/mb/bin/mb-gcc: /lib/tls/libc.so.6: version 'GLIBC_2.4' not found (required
    by /sbin/mb/bin/mb-gcc)

    Press <ENTER> to continue...



    None of this has yet solved the problem of "You must configure in a separate build directory." Any ideas?

  9. #8
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Quote Originally Posted by serec_mard View Post
    Makeconfig:84: sysdeps/../config.make: No such file or directory
    The GNU C library has not been configured.
    Run 'configure' to configure it before building.
    Try 'configure --help' for more details.
    Did you try running configure?

    When building gcc it's a good idea to make a temporary directory from which to compile it. Use mkdir to make this temp directory, then cd to it, and run configure from there.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  10. #9
    Ok, I made another dir, and I'm running configure from it. configure checks some stuff, then checks for compilers. It doesn't find any - "configure: error: no acceptable C compiler found in $PATH".

  11. #10
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Dammit. Of course!! I forgot. "Make" requires a compiler in order to work. The problem is that you don't have a compiler with which to compile your compiler!

    You need to either, download a pre-compiled binary (probably from the same resource that you downloaded the source from), or boot from a liveCD to compile the compiler.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •