Find the answer to your Linux question:
Results 1 to 5 of 5
I installed etch netinst on my dell laptop today with xdm and fluxbox. Not sure how to go about getting the wireless card up and running and WPA configured. Googled ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    30

    wifi


    I installed etch netinst on my dell laptop today with xdm and fluxbox. Not sure how to go about getting the wireless card up and running and WPA configured. Googled around, but not much info outside a traditional desktop environment.

    I put the ip2200 firmware in /hotplug/firmware and installed the wpasupplicant. Where to go from here?

    I would like to learn how to do this from the command line; if not a gnome utility would do.

    If anyone could point me in the right direction I would appreciate it.

    thanks,
    m

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    is that the right place, or is it /lib/firmware?

    wait a minute, I think its /usr/lib/hotplug/firmware/

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    30
    well, yeah, /usr/lib/hotplug/firmware

    just too lazy to type it all out

    sorry...

  4. #4
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    and after a reboot still no wifi?

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    30

    fluxbox? startfluxbox?

    I got wifi running but it's still not right.

    After reboot I still have no network-manager gui. However, if I type in the command "startfluxbox" (from inside an already established fluxbox session) I get, after the predictable warnings that 'another window manager is running', a new instance of fluxbox with the network manager in the toolbar. So now I can log into my WPA enabled network.

    Maybe I'm slow, but this really makes no sense to me. Why would fluxbox initialize itself on boot, apparently with the "fluxbox" parameter, and then make me run "startfluxbox" to access my wifi?

    I have Googled around, but nothing I have found has helped me to change the default initialization to startfluxbox in debian.

    This also causes problems running some programs. I get error message

    Xlib: connection to: ":0.0" refused by server

    I'm guessing because I'm trying to run these programs on a second instance of fluxbox and the xserver won't allow it.

    So if anyone can help me... maybe my assumptions are all wrong, but it seems that i need to initialize into the "startfluxbox" parameter at bootup. Does anyone know where this config file would be.

    Or, if I could just get debian to boot into command line mode and I could manually enter "startfluxbox" I would be more than happy. I haven't figured out how debian runlevels permit this.

    thx
    m

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •