Find the answer to your Linux question:
Results 1 to 3 of 3
This is a lengthy post but I am trying to give enough information for someone to be able to help me and also to let others who are having similar ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    33

    Epson scanner in debian lenny


    This is a lengthy post but I am trying to give enough information for someone to be able to help me and also to let others who are having similar problems see what I have done so that any answers may be helpful to them.
    I am running Debian lenny on a single boot computer. The scanner is an Epson Perfection 1200 Photo. It is plugged in, turned on, and as you can see, it is recognized some places below. I have tried to figure out how to use the epkowa program but I have not succeded yet.


    Scanner information

    Listing of /etc

    debian:/etc# ls /etc
    acpi dictionaries-common init.d Muttrc.d rmt
    adduser.conf dirmngr initramfs-tools mysql rpc
    adjtime discover.conf.d inittab nanorc samba
    aliases discover-modprobe.conf inputrc netatalk sane.d
    alsa dm iproute2 netscsid.conf scrollkeeper.conf
    alternatives dpkg issue network scsi_id.config
    anacrontab emacs issue.net NetworkManager securetty
    analog.cfg email-addresses java networks security
    apache2 enscript.cfg kbd news selinux
    apm esound kde3 nsswitch.conf sensors.conf
    apparmor.d exim4 kernel-img.conf openoffice services
    apt exports kerneloops.conf opt sestatus.conf
    at.deny fonts ksysguarddrc pam.conf sgml
    avahi foomatic ldap pam.d shadow
    bash.bashrc fstab ld.so.cache pango shadow-
    bash_completion gai.conf ld.so.conf papersize shells
    bash_completion.d gconf ld.so.conf.d passwd skel
    bind gdm libao.conf passwd- smartd.conf
    bindresvport.blacklist gimp libgda perl smartmontools
    bluetooth gnokiirc libpaper.d php5 sound
    bonobo-activation gnome lisarc pm spamassassin
    ca-certificates gnome-app-install locale.alias pmount.allow ssh
    ca-certificates.conf gnome-vfs-2.0 locale.gen postgresql ssl
    calendar gnome-vfs-mime-magic localtime postgresql-common sudoers
    chatscripts gre.d logcheck ppp sysctl.conf
    complete.tcsh groff login.defs profile sysctl.d
    console group logrotate.conf protocols syslog.conf
    console-tools group- logrotate.d pulse terminfo
    cron.d gshadow lsb-base purple texmf
    cron.daily gshadow- magic python tidy.conf
    cron.hourly gssapi_mech.conf magic.mime python2.4 timezone
    cron.monthly gtk-2.0 mail python2.5 ts.conf
    crontab hal mailcap qpopper.conf ucf.conf
    cron.weekly hdparm.conf mailcap.order qt3 udev
    csh hesiod.conf mailname rc0.d updatedb.conf
    csh.cshrc host.conf mail.rc rc1.d uswsusp.conf
    csh.login hostname manpath.config rc2.d vga
    csh.logout hosts menu rc3.d vim
    cups hosts.allow menu-methods rc4.d w3m
    cvs-cron.conf hosts.deny mime.types rc5.d wgetrc
    cvs-pserver.conf hp mke2fs.conf rc6.d wodim.conf
    dbus-1 htdig modprobe.d rc.local wpa_supplicant
    debconf.conf iceweasel modules rcS.d X11
    debian_version identd.conf motd rearj.cfg xdg
    default identd.key motd.tail reportbug.conf xml
    defoma idmapd.conf mtab resolvconf ytalkrc
    deluser.conf imlib mtools.conf resolv.conf
    dhcp3 inetd.conf Muttrc resolv.conf.pppd-backup
    debian:/etc#

    Listing of fstab by running “nano /etc/fstab” command

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda1 / ext3 errors=remount-ro 0 1
    /dev/sda5 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

    Listing of “sane-find-scanner
    debian:/etc# sane-find-scanner

    # sane-find-scanner will now attempt to detect your scanner. If the
    # result is different from what you expected, first make sure your
    # scanner is powered up and properly connected to your computer.

    # No SCSI scanners found. If you expected something different, make sure that
    # you have loaded a kernel SCSI driver for your SCSI adapter.

    found USB scanner (vendor=0x04b8 [EPSON], product=0x0104 [Perfection1200]) at libusb:007:002
    found USB scanner (vendor=0x03f0 [HP], product=0x8604 [Deskjet 5400 series]) at libusb:004:004
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    # Not checking for parallel port scanners.

    # Most Scanners connected to the parallel port or other proprietary ports
    # can't be detected by this program.
    debian:/etc#

    Listing $ scanimage command

    scanimage: no SANE devices found
    marshall@debian:~$

    Listed below is a portion of etc showing sane.d listed.
    -rw-r--r-- 1 root root 887 2008-04-04 12:09 rpc
    drwxr-xr-x 2 root root 4096 2008-11-27 16:15 samba
    drwxr-xr-x 3 root root 4096 2009-01-05 11:45 sane.d
    -rw-r--r-- 1 root root 23 2007-12-18 08:02 scrollkeeper.conf
    -rw-r--r-- 1 root root 666 2007-08-05 23:12 scsi_id.config
    -rw-r--r-- 1 root root 1254 2008-06-12 18:39 securetty
    earlier I changed to the sane.d directory but not at $etc prompt the “cd /sane.d” command says no such directory.

    marshall@debian:/etc$ cd /sane.d
    bash: cd: /sane.d: No such file or directory
    marshall@debian:/etc$

    I got to sane.d by using su

    -rw-r--r-- 1 root root 452 2009-01-11 08:23 epson2.conf
    -rw-r--r-- 1 root root 831 2009-01-11 08:16 epson.conf
    -rw-r--r-- 1 root root 1221 2008-06-24 16:02 fujitsu.conf
    -rw-r--r-- 1 root root 586 2008-06-24 16:02 genesys.conf

    Nano epson2.conf gives the following
    # Parallel port
    #pio 0x278
    #pio 0x378
    #pio 0x3BC

    # USB
    usb

    # For libusb support for unknown scanners use the following command
    # usb <product ID> <device ID>
    # e.g.:
    # usb 0x4b8 0x110
    #next line added Jan 11, 09 trying to set up epson scanner.
    usb 0x4b8 0x104
    # Network
    #
    # net 192.168.1.123
    net autodiscovery

    Next is Epson.conf file partial content
    GNU nano 2.0.7 File: epson.conf

    # accurate, it's device ID) is known to the backend.
    usb
    # For libusb support for unknown scanners use the following command
    # usb <product ID> <device ID>
    # e.g.:
    # usb 0x4b8 0x110
    # And for the scanner module, use the following configuration:
    #usb /dev/usbscanner0
    #usb /dev/usb/scanner0
    usb 0x4b8 0x104
    usb /dev/usb/scanner0

    /etc/inetd.conf edited with nano as follows

    # run this only on machines acting as "boot servers."
    What does this mean? Should I change this file back?
    #:RPC: RPC based services

    #:HAM-RADIO: amateur-radio services

    #:OTHER: Other services
    #<off># netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
    swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat
    #<off># sane-port stream tcp nowait saned:saned /usr/sbin/saned saned
    # Nest line changed to <on> Jan 11, 09 trying to get scanner to work.
    <on># sane-port stream tcp nowait saned:saned /usr/sbin/saned saned


    Nothing seems to get the scanner to go.

  2. #2
    Just Joined! mrrangerman's Avatar
    Join Date
    Jul 2008
    Posts
    34
    Make sure your user is part of the scanner group, go to Desktop > Administration > Users and Groups it will ask you for your root passwd, after you login, highlight your user, then click on properties, go to the User privileges tab and check the Use scanner box.

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    33
    Thanks for your reply. I took the action but signed out before I got to check and see if it worked. Apparently I changed the wrong permission or something. The computer will not allow me to log in any more. I am back on my old winddows computer. Is there a way to get back in without having to reload the system and start over?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •