Find the answer to your Linux question:
Results 1 to 3 of 3
Please excuse me, for I am new. I just installed Debian and am trying to install some applications. However, I get an error saying that I don't have libc6: However, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Raize's Avatar
    Join Date
    Jan 2009
    Location
    Colorado, USA
    Posts
    28

    Supposedly missing libc6


    Please excuse me, for I am new. I just installed Debian and am trying to install some applications. However, I get an error saying that I don't have libc6:





    However, according to apt-get I already have it and it's up-to-date:




    I'm new to Linux so I really have no idea where to go from here. Any help would be greatly appreciated.




    If it helps:

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    it looks like it depends on the following:
    libc6 (>= 2.7-1), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.2.1)

    Code:
     apt-cache show libboost-date-time1.34.1
    so is your libc6 = or greater than 2.7-1
    Code:
    dpkg -l libc6
    dpkg -l libgcc1
    dpkg -l libstdc++6
    looks like you have etch and having downloaded a package that is available for lenny. since its available for lenny then it was built against lenny packages

    you can either build the package from source, upgrade to lenny, or stay on etch and use apt-pinning to install the lenny package Apt-Pinning for Beginners

  3. #3
    Just Joined! Raize's Avatar
    Join Date
    Jan 2009
    Location
    Colorado, USA
    Posts
    28
    I upgraded and that fixed the problem. Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •