Find the answer to your Linux question:
Results 1 to 3 of 3
Hi. I work in the virtual consoles alot (Ctrl+Alt+F1, F2...) on a Debian Lenny amd64 system. What is the proper way to set the font for the virtual console? I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10

    Setting the font for the virtual console


    Hi. I work in the virtual consoles alot (Ctrl+Alt+F1, F2...) on a Debian Lenny amd64 system. What is the proper way to set the font for the virtual console? I know the fonts are in /usr/share/consolefonts, and I know that I can set the font each time I log in by putting a consolechars statement in my bash profile. But this causes an error message whenever I ssh into my account from another computer, or use an X terminal.

    I just want to set the font for that computer, not every terminal that logs in.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to set vga value in kernel line?
    Add vga=778 at the end of kernel line in /boot/grub/menu.lst and reboot machine. Check other resolutions here under Linux video mode numbers title.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    Thanks, but I did already know how to set the resolution (which really helped a lot). However, I was considering a different font. I've tried out several using consolechars and found them to be more visually appealing than the default font. Does anyone know what is the correct way of setting this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •