Find the answer to your Linux question:
Results 1 to 2 of 2
Somehow (I don't know for sure) when I was installing GIMP & Inkscape (last time I install two prgrams at the same time) via apt-get something went wrong and I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1

    interrupted dpkg can't be fixed because of filesystem location issue?


    Somehow (I don't know for sure) when I was installing GIMP & Inkscape (last time I install two prgrams at the same time) via apt-get something went wrong and I got a message reading something-swap(space-I-think)-something (I won't lie, I was in a hurry so I just hit enter without reading throughly, now when I try to make an apt-get upgrade I get this:
    Code:
    debian:/home/oncozerov# apt-get upgrade
    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    Obviously I ran dpkg and this is what I get:
    Code:
    debian:/home/oncozerov# dpkg --configure -a
    Setting up initramfs-tools (0.92o) ...
    update-initramfs: deferring update (trigger activated)
    Setting up linux-image-2.6.26-1-686 (2.6.26-13) ...
    Running depmod.
    Running mkinitramfs-kpkg.
    mkinitramfs-kpkg failed to create initrd image.
    Failed to create initrd image.
    dpkg: error processing linux-image-2.6.26-1-686 (--configure):
     subprocess post-installation script returned error exit status 9
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-2.6.26-1-686
    mkinitramfs: missing sdb root /dev/sdb1 /sys entry
    mkinitramfs: workaround is MODULES=most
    mkinitramfs: Error please report the bug
    update-initramfs: failed for /boot/initrd.img-2.6.26-1-686
    dpkg: subprocess post-installation script returned error exit status 1
    Now, I KNOW (sure everybody says the same thing) that the problem is the sdb/sdb1 part (which I have marked in red) because originally my machine didn't boot unless I hit 'e' during GRUB to alter the path (that's permanently modified now) otherwise I got a couldn't mount filesystem, my filesystem is in sda (a fact) but I think because I installed from an USB stick and I just have a few weeks playing with linux (I have Debian Lenny installed by the way) I probably did something wrong during the installation so I got that filesystem problem, I'm convinced that issue is totally related to this dpkg error and all I wish for is a pointer as of where is what I' suppoused to modify so that my machine will forever forget that sdb inexistant location.
    I hope this goes here, and yes, I've tried reading about dpkg, and initramfs, mkinitramfs, pendriving linux, but still I can't find aomething that'll get my in the right direction.
    I almost forgot, MODULES is already set to 'most'.
    That's it, thank you.

  2. #2
    Linux User
    Join Date
    Feb 2006
    Posts
    484
    So you have installed debian on a pendrive.

    Do you use the same interface(the same hole ) when you are booting from the pendrive?
    When linux booting the udev daemon dynamically build the hardware nodes.
    One your pendrive is identifyed as sdb , other time as sda.

    Use the same hole. Or use uuid for disks in /etc/fstab.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •