Find the answer to your Linux question:
Results 1 to 2 of 2
OSS expired and needed to be upgraded. Downloaded and installed oss-linux-4.1-1051_i386.deb. Results: XMMS playback is good. Skype playback is good. Skype input fails. command osstest: SNDCTL_SYSINFO failed: Invalid argument Cannot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! bezdomny's Avatar
    Join Date
    Apr 2007
    Location
    North-Central California
    Posts
    97

    [SOLVED] Lenny upgrade to OSS 4.1: mixed results


    OSS expired and needed to be upgraded. Downloaded and installed oss-linux-4.1-1051_i386.deb.

    Results:

    XMMS playback is good. Skype playback is good. Skype input fails.

    command osstest:
    SNDCTL_SYSINFO failed: Invalid argument
    Cannot get system information. Perhaps you are not running OSS 4.x
    but some slightly incompatible sound subsystem.
    command ossdetect -v:
    /usr/lib/oss/etc/devices.list: No such file or directory
    command soundon:
    cat: /usr/lib/oss/version.dat: No such file or directory
    /usr/lib/oss/etc/devices.list: No such file or directory
    No /usr/lib/oss/etc/installed_drivers - cannot continue
    command ossmix:
    Error: OSS version 3.9 or later is required
    Any help or advice would be greatly appreciated. Please don't hesitate to let me know if you need more info.

    Thanks!

  2. #2
    Just Joined! bezdomny's Avatar
    Join Date
    Apr 2007
    Location
    North-Central California
    Posts
    97

    *solved* Debian Lenny upgrade to OSS 4.1: mixed results

    Manually purging the dpkg status file with this procedure and then re-installing OSS with command dpkg -i oss-linux-4.1-1051_i386.deb resulted in a successful installation. Commands osstest and ossdetect -v are now nominal, aumix is now nominal, and I now have both input and output with Skype. Thanks to temujin at the OSS community at 4front.com for the solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •