Find the answer to your Linux question:
Results 1 to 2 of 2
I am having difficulty getting sound to work. I have the Dell OEM SB Live!, so module snd-emu10k1x! Here are the steps I have taken thus far to get things ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1

    ALSA 1.0.6a and Dell SB Live!


    I am having difficulty getting sound to work. I have the Dell OEM SB Live!, so module snd-emu10k1x! Here are the steps I have taken thus far to get things underway.

    I compiled kernel 2.6.8.1 successfully with Sound Support built in. I excluded ALSA from the Kernel compile.

    I then used module-assistant and successfully compiled the Nvidia drivers. I have nice graphics now and can read this webpage, yeah!

    Next I downloaded alsa-driver-1.0.6a.tar.bz2 from the ALSA Project web page. I untarred the tar.bz2 file in my /usr/src directory. It created the alsa-driver-1.0.6a directory there.

    Then I followed the Quick Install instructions:
    I did the ./configure which seemed to work fine.
    I ran make which seemed to work fine.
    I ran make install which seemed to work fine.
    I ran ./snddevices which looked good.

    Now things get hairy. I am running Debian (testing) Linux. My /etc/modules.conf file says I'm not supposed to edit it under any circumstance and should instead look in my /etc/modutils directory. Inside that is a file called alsa-base. It is currently empty.

    Next, if I run modprobe snd-emu10k1x I get a whole slew of Unresolved Symbols (as an aside, where does this get logged so that I can copy it into these posts??).

    Upon rebooting my computer and entering KDE as root, I get the sound error relating to /dev/dsp, a device not found. A similar error shows up on trying to play an audio file in XMMS.

    I should say I am Linux Newbie so type slowly

    I'd appreciate any help, thanks.

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7
    Try running:

    # alsaconf

    as root.

    This should generate the /etc/modutils/alsa-base file for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •