Find the answer to your Linux question:
Results 1 to 4 of 4
Windows partition won't mount automatically at boot.. It's accessible only to root., despite "user" option in fstab . gparted lists NTFS partition as /dev/hda1 Output of parted : Code: Number ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! bezdomny's Avatar
    Join Date
    Apr 2007
    Location
    North-Central California
    Posts
    97

    [SOLVED] fstab: should be child's play


    Windows partition won't mount automatically at boot.. It's accessible only to root., despite "user" option in fstab.

    gparted lists NTFS partition as
    /dev/hda1
    Output of parted:
    Code:
    Number  Start   End     Size    Type     File system  Flags
     1      32.3kB  40.0GB  40.0GB  primary  ntfs         boot
    Pertinent line in fstab:
    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/hda1 /media/windows ntfs auto,user,noexec,rw,sync 0 0
    What am I missing? Thanks in advance for any help available.

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Does it give you an error message when you give a

    mount -a command?

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Are you sure its hda1 not sda1? Check the output of fdisk -l command.
    Code:
    su -
    fdisk -l
    auto,user,noexec,rw,sync 0 0
    There is no need to use all those options. defaults,umask=0 is enough.
    Code:
    /dev/hda1 /media/windows ntfs defaults,umask=0   0  0
    In case it doesn't work, post the output of mount -a command as suggested by rcgreen.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! bezdomny's Avatar
    Join Date
    Apr 2007
    Location
    North-Central California
    Posts
    97

    fstab: should be child's play

    Thanks, everyone. Yes, umask=022, (picked up at Debian Forums) was the solution. Don't know the difference between umask=0 and umask=022, but the latter works, so I'm satisfied. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •