Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all. I just did yet another fresh install of Debian lenny using the ipw2200.fw for network installation. And im _almost_ satisfied except that i cant see any other SSID's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52

    Network Manager doesnt pick up other signals


    Hi all. I just did yet another fresh install of Debian lenny using the ipw2200.fw for network installation. And im _almost_ satisfied except that i cant see any other SSID's nor my own for that matter. Everything as far as the device seems to be working.

    iwconfig shows up nicely, ifconfig shows both eth0 and eth1

    Sample:

    Code:
    Inferno:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:41:13:3e:f9  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:16 
    
    eth1      Link encap:Ethernet  HWaddr 00:16:6f:25:88:01  
              inet addr:10.23.2.3  Bcast:10.23.2.255  Mask:255.255.255.0
              inet6 addr: fe80::216:6fff:fe25:8801/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4236 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3430 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:4297964 (4.0 MiB)  TX bytes:464266 (453.3 KiB)
              Interrupt:21 Memory:a8401000-a8401fff
    And if i did iwconfig....

    Code:
    Inferno:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11g  ESSID:"Wireless_Network"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:18:39:DB:58:BE   
              Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=84/100  Signal level=-46 dBm  Noise level=-89 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    So whats the problem??


    I would just like network manager to work the way its supposed to. Any suggestions, thanx in advance!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Check to see if it has wireless enabled. Right-click on the NetworkManager icon in the taskbar, next to the Date/Time. Make sure that Enable Wireless has a check in the box next to it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Heya, waterhead. No i dont see Enable box for wireless. Just for networking. Could that mean something needs to be installed?

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I don't know how Debian does things, but this seems like a clue to what is wrong.

    Is there a configuration where you can tell it to use NetworkManager for the wireless? If not a GUI, maybe a config file. I read that /etc/network/interfaces controls the network card. If the wireless is listed, comment it out and restart NM or reboot. See if that helps.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Yes, you had the right idea as had i. Apparently that file doesnt like the interface. Why i dont know. But i edited /etc/network/interfaces and commented out my wireless interfaces name.

    Sample:

    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #allow-hotplug eth1
    #iface eth1 inet dhcp
     # wireless-* options are implemented by the wireless-tools package
    wireless-mode managed
    wireless-essid any
    Then reset Network Manager

    Code:
    /etc/init.d/networking stop
    /etc/init.d/networking start
    But that still did nothing. So i took your advice from the beginning and right clicked the network manager applet, but wireless still wasnt there. So for kicks i unchecked Wired Network and re-checked it. For some reason the wireless network one showed up. Maybe it had something to do what what i've done in /etc/network/interfaces or not. All i know is im glad im able to use it again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •