Find the answer to your Linux question:
Results 1 to 5 of 5
Gday Guys, I have a strange problem, I have setup a samba server and it is working great. The problem that i have is that when i put the share ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Australia (Down Under)
    Posts
    141

    correct fstab wont mount drives on boot


    Gday Guys,


    I have a strange problem, I have setup a samba server and it is working great. The problem that i have is that when i put the share into my fstab file it dosent map the network drive. i dont believe that it is a problem with the fstab file because when i run
    Code:
    mount -a
    as root it mounts the network drive.

    general info

    Distro Lenny
    Using CIFS

    fstab file is
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    errors=remount-ro 0       1
    /dev/hda5       none            swap    sw              0       0
    
    //10.135.60.10/Multimedia/ /Multimedia cifs exec,user=multimedia,password=multimedia,uid=1000 0 0
    any ideas?
    Linux is the OS of tomorrow, Here today!!

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    try using smbfs instead of cifs
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  3. #3
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Australia (Down Under)
    Posts
    141
    Will give it a try in a few minutes but Im fairly sure that it says smbfs has been replaced with cifs

    Thanks for the reply, I will let you know soon
    Linux is the OS of tomorrow, Here today!!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Feb 2006
    Posts
    484
    cifs replaced smbfs and suggested to use instead of smbfs

    your fstab is correct but the auto options missing
    try this

    //10.135.60.10/Multimedia/ /Multimedia cifs exec,user=multimedia,password=multimedia,uid=1000,auto 0 0

  6. #5
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Australia (Down Under)
    Posts
    141
    hmmm.... will give it a try tomorrow.. thanks mate
    Linux is the OS of tomorrow, Here today!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •