Find the answer to your Linux question:
Results 1 to 8 of 8
Linux is completely new to me, so be gentle. I have installed debian/linux recently and have had zero success in getting onto my home network (2 pc's and a few ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4

    connecting to home network and internet with new install


    Linux is completely new to me, so be gentle.
    I have installed debian/linux recently and have had zero success in getting onto my home network (2 pc's and a few wireless laptops- all Windows)

    i have cable internet through a Motorola cable modem which feeds my linksys broadband router.

    On 3 separate attempts the debian installer tried to autoconfig dhcp and failed.
    I figured it was no big deal and i would be able to manually configure later.

    I have messed with the network settings and have looked at the help files and other user threads that were posted. the GUI for network setting looks so easy, but alas i am more ignorant of the nomenclature than i should be.

    A poster named zinger, about a year ago, looked like he had the same difficulty, POSTED:"Networking not functional in new Debian installation" (unfortunately his last entry said he was giving up on linux and going back to windows). If anyone can help it would be great.

    SYSTEM/Administration/Network: Under connections it just reads: Wired connection address: dhcp - it does not have my actual network card listed as some tutorials have shown.
    Under General my pc name(host) is just debian by default and not sure what the domain name should be.
    Not sure about DNS entries (servers, search domains?)
    Hosts? no entries here either.

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    15
    Can you tell us the result of the ifconfig command !

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    eth0 Link encap:Ethernet HWaddr 00:0a:e6:a1:6e:f0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets: 0 blah blah 0
    TX blah blah all zeros
    collisions: zeros again
    RX bytes:0 (0.0 B) TX (0.0 B)
    Interrupt:19 Base address 0xd400

    lo Link encap:Local Loopback
    inet addr:127:0.0.1 Mask: 255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX Packets:8 then zeros
    TX packets:8 zeros again
    collision 0
    RX bytes560 (560.0 B) TX bytes:560 (560.0 B)

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    15
    I can't tell you what's the problem from that, but try these commands and tell me the result:
    ifconfig eth0 up
    dhclient eth0
    ifconfig eth0

  5. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    ifconfig eth0 up: did nothing
    ifconfig eth0: same as i replied for ifconfig without the lo part
    dhclient eth0: Int. sys. cons copyright and such
    Listening on LPF/eth0/00:0a:e6:a1:6e:f0
    Sending on [same as above]
    Sending on Socket/fallback
    DHCDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
    ditto interval 14, 13, 7, 12, 10
    NoDHCPOFFERS received.
    No working leases in persistent database - sleeping.

  6. #6
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Just for kicks, try a different ethernet cable. If other computers
    are working with this router, it's unlikely to be a router problem,
    but your system is broadcasting a request for DHCP and getting
    no offers, so first, check the wire.

  7. #7
    Just Joined!
    Join Date
    Apr 2009
    Posts
    4
    okay, swapped the wire with my existing pc already on the router. both work with the other computer but not with the linux one. I added a different network card to see if the existing card was bad. still no DHCPOFFERS received.

  8. #8
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    could be a bug in debian driver, what is your card?
    Code:
    /sbin/lspci | grep -i eth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •