Find the answer to your Linux question:
Results 1 to 5 of 5
Does it work to use the Emerald Window Manager i Debian? Im running Compiz + AWN now, but i want to have Emerald also so how do i install it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Location
    Sweden
    Posts
    11

    Emerald Window Manager i Debian


    Does it work to use the Emerald Window Manager i Debian?
    Im running Compiz + AWN now, but i want to have Emerald also so how do i install it in Debian?
    Im running Debian Lenny x64.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    There used to be a fellow who set up a repository for all the compiz stuff for Debian, called the Repository of Shame but he stopped maintaining the site in Dec. 2008. Since then, if it isn't in the Debian repos, I don't know where to get it outside of building it from source yourself.

    If you're adventurous, you can find the source code here. You'll need the version that corresponds with whichever compiz version you're running. You can find that out by typing dpkg -l compiz

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Location
    Sweden
    Posts
    11
    Ok, thanks i'll check it out.

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Location
    Sweden
    Posts
    11
    I build it from source and installed it and worked fine.
    But it seems to need the file "libemeraldengine0" in order to make Emerald work.
    As it is now when i enable Emerald as window decorator i have no borders and Emerald theme manager wont start when i click it?
    And in Compiz under Window Border it is: emerald --replace

    And then i thought it has to be "libemeraldengine0" that is missing??

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Location
    Sweden
    Posts
    11
    Quote Originally Posted by Rim_Frost View Post
    I build it from source and installed it and worked fine.
    But it seems to need the file "libemeraldengine0" in order to make Emerald work.
    As it is now when i enable Emerald as window decorator i have no borders and Emerald theme manager wont start when i click it?
    And in Compiz under Window Border it is: emerald --replace

    And then i thought it has to be "libemeraldengine0" that is missing??

    I've got it all solved now. I added the "Repository of Shame" to the sources.list then installed everything, after that i took "Mark all upgrades" in Synaptic and updated everything. So now its working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •