Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Blacksburg, VA

    USB Mouse/Network Modules

    Hi while installing Debian 3.0r2(woody) I've run into some difficulties.

    1.) I can't seem to get Debian to recognize my USB mouse, and I can't use a PS/2 on my laptop When selecting my mouse port, I chose /dev/input/mice which according to the installation instructions I have is the proper designation for USB mice. Because of this, I'm stuck in text mode.

    2.) I connect to the internet via an ethernet connection in my dorm. Debian doesn't detect my network card.

    3.) I have an ATi mobility range video card, but if I choose the ATI option for video card, I get a bunch of error messages on startup. (I've partially resolved this one by using the generic vesa option, but I'd prefer to take advantage of the hardware I have if possible

    So, what I'm asking is, are there any specific modules I should be adding and what are they, or is there something else I'm missing?

    Any help would be greatly appreciated.

  2. #2
    Don't know how helpful this is -

    Have you run
    # modprobe mousedev

    From it seems you do need to specify "ati" as your driver, as you did, but there doesn't seem to be many other people with the same problem (that's always the way, isn't it?).

    Post the errors, and perhaps the mouse model you have. Oh, and the network card model. It's usually as simple as adding the lines:

    auto eth0
    iface eth0 inet dhcp

    to /etc/network/interfaces, and perhaps adding the driver name for your card in /etc/modules. I'm no expert, but there may be someone with a solution.

    Also - why use stable when there's testing?! It's rock solid, trust me. And the installer should do this for you on the sarge beta-installer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts